aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mesagl
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
committerasami <asami@FreeBSD.org>1998-11-11 13:37:39 +0800
commit559e1bc28bd975c38b561de15be3918ba1f71b5e (patch)
treecda169bf1e41b7166c2d2febd3d858c1411d0e64 /graphics/mesagl
parent7aed28166a84f266be861367fc9a1add43f9219a (diff)
downloadfreebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.gz
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.tar.zst
freebsd-ports-gnome-559e1bc28bd975c38b561de15be3918ba1f71b5e.zip
Use bsd.port.{pre,post}.mk. Either use them to avoid having to define
something already there (PORTOBJFORMAT, OSVERSION) or move stuff from after .include <bsd.port.mk> to before. (This is not by any means the complete list but just the ones I've noticed recently.)
Diffstat (limited to 'graphics/mesagl')
-rw-r--r--graphics/mesagl/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index 5781bf2fc0dc..67a6262036ae 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -3,7 +3,7 @@
# Date created: Tue Feb 7 12:02:49 1995
# Whom: hsu
#
-# $Id: Makefile,v 1.28 1998/09/26 23:33:10 steve Exp $
+# $Id: Makefile,v 1.29 1998/10/01 02:17:42 jseger Exp $
#
DISTNAME= MesaLib-3.0
@@ -20,6 +20,18 @@ WRKSRC= ${WRKDIR}/Mesa-3.0
USE_X_PREFIX= yes
LIBS= libMesaGL libMesaGLU
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+ALL_TARGET= freebsd-elf
+SHLIB_VERSION= 14
+GLUT_VERSION= 3
+.else
+ALL_TARGET= freebsd
+SHLIB_VERSION= 14.0
+GLUT_VERSION= 3.7
+.endif
+
do-install:
.for file in ${LIBS}
${INSTALL_DATA} ${WRKSRC}/lib/${file}.a ${PREFIX}/lib
@@ -38,14 +50,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/include/GL/* ${PREFIX}/include/GL
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-ALL_TARGET= freebsd-elf
-SHLIB_VERSION= 14
-GLUT_VERSION= 3
-.else
-ALL_TARGET= freebsd
-SHLIB_VERSION= 14.0
-GLUT_VERSION= 3.7
-.endif
+.include <bsd.port.post.mk>