aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/meshviewer/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-02-08 18:27:24 +0800
committerijliao <ijliao@FreeBSD.org>2003-02-08 18:27:24 +0800
commitc92bd29f7606e4674195b7d608a19f1fee4cdf2b (patch)
tree10dcacd8edd90a307749ec3cd605964594b07ca0 /graphics/meshviewer/Makefile
parent6e93ea2a09a41855347ea4aa9cbf471636ab3cf1 (diff)
downloadfreebsd-ports-gnome-c92bd29f7606e4674195b7d608a19f1fee4cdf2b.tar.gz
freebsd-ports-gnome-c92bd29f7606e4674195b7d608a19f1fee4cdf2b.tar.zst
freebsd-ports-gnome-c92bd29f7606e4674195b7d608a19f1fee4cdf2b.zip
add meshviewer 0.1.2
Mesh Viewer
Diffstat (limited to 'graphics/meshviewer/Makefile')
-rw-r--r--graphics/meshviewer/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
new file mode 100644
index 000000000000..41432922b822
--- /dev/null
+++ b/graphics/meshviewer/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: meshviewer
+# Date created: Jun 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+
+PORTNAME= meshviewer
+PORTVERSION= 0.1.2
+CATEGORIES= graphics
+MASTER_SITES= http://www.dai.ed.ac.uk/homes/helmutc/mesh_viewer/
+DISTNAME= mview-src-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_MESA= yes
+USE_QT_VER= 3
+USE_GMAKE= yes
+MAKE_ENV= MOC="${MOC}" QTDIR="${X11BASE}" \
+ CPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${QTCFGLIBS} ${PTHREAD_LIBS}"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mview ${PREFIX}/bin
+
+.include <bsd.port.mk>