aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/meshviewer
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-08-28 14:26:49 +0800
committerkrion <krion@FreeBSD.org>2004-08-28 14:26:49 +0800
commit517217573f27c61b5765329dadef9c89725f1a85 (patch)
treecc232b0775fdd2151e0ef9429dfad7bede04ddb1 /graphics/meshviewer
parentf5727c730482ed6476705086437ccfb42c06b98d (diff)
downloadfreebsd-ports-gnome-517217573f27c61b5765329dadef9c89725f1a85.tar.gz
freebsd-ports-gnome-517217573f27c61b5765329dadef9c89725f1a85.tar.zst
freebsd-ports-gnome-517217573f27c61b5765329dadef9c89725f1a85.zip
Fix build with gcc-3.4
PR: ports/71060 Submitted by: Ports Fury
Diffstat (limited to 'graphics/meshviewer')
-rw-r--r--graphics/meshviewer/Makefile2
-rw-r--r--graphics/meshviewer/files/patch-mesh::matrix3.h12
-rw-r--r--graphics/meshviewer/files/patch-texture::array3d.h10
3 files changed, 24 insertions, 0 deletions
diff --git a/graphics/meshviewer/Makefile b/graphics/meshviewer/Makefile
index e3bcf8e39b25..708598b7f009 100644
--- a/graphics/meshviewer/Makefile
+++ b/graphics/meshviewer/Makefile
@@ -21,6 +21,8 @@ MAKE_ENV= MOC="${MOC}" \
QTCPPFLAGS="${QTCPPFLAGS} ${PTHREAD_CFLAGS}" \
QTCFGLIBS="${QTCFGLIBS} ${PTHREAD_LIBS}"
+CFLAGS+= -fpermissive
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mview ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/graphics/meshviewer/files/patch-mesh::matrix3.h b/graphics/meshviewer/files/patch-mesh::matrix3.h
new file mode 100644
index 000000000000..e787ec606e5b
--- /dev/null
+++ b/graphics/meshviewer/files/patch-mesh::matrix3.h
@@ -0,0 +1,12 @@
+--- mesh/matrix3.h.orig Sun Nov 9 21:01:16 2003
++++ mesh/matrix3.h Fri Aug 27 12:44:20 2004
+@@ -9,7 +9,8 @@
+ #ifndef _MATRIX3_H
+ #define _MATRIX3_H
+
+-#include <stdarg.h>
++#include <cstdarg>
++#include <cmath>
+
+ #define SIZE 3
+
diff --git a/graphics/meshviewer/files/patch-texture::array3d.h b/graphics/meshviewer/files/patch-texture::array3d.h
new file mode 100644
index 000000000000..61a8a0bd58e7
--- /dev/null
+++ b/graphics/meshviewer/files/patch-texture::array3d.h
@@ -0,0 +1,10 @@
+--- texture/array3d.h.orig Sun Nov 9 21:13:01 2003
++++ texture/array3d.h Fri Aug 27 12:53:54 2004
+@@ -16,6 +16,7 @@
+
+ Array3D()
+ {
++ int x, y, z;
+ x=y=z=0;
+ data=NULL;
+ }