aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mhgui
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-30 02:19:06 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-30 02:19:06 +0800
commit294c128543f25743190e5fc9904e26a14f7491a5 (patch)
tree16d4b6da6d61316199228469a5423ec1e5d056ff /graphics/mhgui
parentc82d5bf86553d902cff80f5af6dff7e11f801ee6 (diff)
downloadfreebsd-ports-gnome-294c128543f25743190e5fc9904e26a14f7491a5.tar.gz
freebsd-ports-gnome-294c128543f25743190e5fc9904e26a14f7491a5.tar.zst
freebsd-ports-gnome-294c128543f25743190e5fc9904e26a14f7491a5.zip
- fix build for png-1.4.1
bump PORTREVISOON
Diffstat (limited to 'graphics/mhgui')
-rw-r--r--graphics/mhgui/Makefile2
-rw-r--r--graphics/mhgui/files/patch-src-ImageData.cpp2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/mhgui/Makefile b/graphics/mhgui/Makefile
index c370704e7279..b2f23e99beee 100644
--- a/graphics/mhgui/Makefile
+++ b/graphics/mhgui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mhgui
PORTVERSION= 0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/makehuman/MakeHuman%20Source/MakeHuman_091
diff --git a/graphics/mhgui/files/patch-src-ImageData.cpp b/graphics/mhgui/files/patch-src-ImageData.cpp
index 62b650580caf..e710a9dc9027 100644
--- a/graphics/mhgui/files/patch-src-ImageData.cpp
+++ b/graphics/mhgui/files/patch-src-ImageData.cpp
@@ -5,7 +5,7 @@
fread(sig, 1, 8, infile);
- if (!png_check_sig((unsigned char *) sig, 8))
-+ if (!png_sig_cmp((unsigned char *) sig, 0, 8))
++ if (png_sig_cmp((unsigned char *) sig, 0, 8))
{
fclose(infile);
return false; // seems not to be a valid png file