aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/multican
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-08-31 17:14:15 +0800
committerdanfe <danfe@FreeBSD.org>2011-08-31 17:14:15 +0800
commitca2601aa1562053f2d05e4a0f1b05fe7c174a6de (patch)
tree9606d25daf0f24367b3871ce0fa533240d0b0e66 /graphics/multican
parent5fa6c3b140d9aad90c6da229c4630cf838147f50 (diff)
downloadfreebsd-ports-gnome-ca2601aa1562053f2d05e4a0f1b05fe7c174a6de.tar.gz
freebsd-ports-gnome-ca2601aa1562053f2d05e4a0f1b05fe7c174a6de.tar.zst
freebsd-ports-gnome-ca2601aa1562053f2d05e4a0f1b05fe7c174a6de.zip
Multican is Canon EOS cameras USB remote control utility for 300D, 350D, 30D,
20D, and 5D. Multican allows scripted remote control of multiple cameras; it is possible to control up to six cameras attached at the same time. Multican communicates with camera directly, without generic library such as provided by gPhoto2, and currently has no GUI, which makes it no replacement for Canon's EOS Utility, but it can be useful nonetheless in various setups, e.g. for astrophotography. WWW: http://multican.sourceforge.net/
Diffstat (limited to 'graphics/multican')
-rw-r--r--graphics/multican/Makefile45
-rw-r--r--graphics/multican/distinfo2
-rw-r--r--graphics/multican/files/patch-usbio.h11
-rw-r--r--graphics/multican/pkg-descr10
4 files changed, 68 insertions, 0 deletions
diff --git a/graphics/multican/Makefile b/graphics/multican/Makefile
new file mode 100644
index 000000000000..845f2fa6bf06
--- /dev/null
+++ b/graphics/multican/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: Multican
+# Date created: 30 Aug 2011
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multican
+DISTVERSION= 0.0.5
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Remote control utility for Canon DSLR cameras
+
+LICENSE= GPLv2
+
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/multican lib/libmultican.so.0 lib/libmultican.so \
+ include/canonio.h include/usbio.h
+PORTDOCS= ChangeLog README TODO
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS= usb:${PORTSDIR}/devel/libusb
+CFLAGS+= -I${LOCALBASE}/include -fPIC
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,endian\.h,sys/&,' ${WRKSRC}/canonio.c \
+ ${WRKSRC}/usbio.c ${WRKSRC}/multican.c
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/libmultican.so.0 ${PREFIX}/lib
+ ${LN} -sf libmultican.so.0 ${PREFIX}/lib/libmultican.so
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/multican/distinfo b/graphics/multican/distinfo
new file mode 100644
index 000000000000..b24020ab0a76
--- /dev/null
+++ b/graphics/multican/distinfo
@@ -0,0 +1,2 @@
+SHA256 (multican-0.0.5.tar.gz) = 66f92c4a8afcf91dbe5081613db5c9da2b7e5222b64d935e64928e0265d5748a
+SIZE (multican-0.0.5.tar.gz) = 23751
diff --git a/graphics/multican/files/patch-usbio.h b/graphics/multican/files/patch-usbio.h
new file mode 100644
index 000000000000..08e0e8263ecb
--- /dev/null
+++ b/graphics/multican/files/patch-usbio.h
@@ -0,0 +1,11 @@
+--- usbio.h.orig 2006-12-18 09:11:04.000000000 +0100
++++ usbio.h 2009-06-24 10:59:54.000000000 +0200
+@@ -182,6 +182,8 @@ static struct {
+ {0x04a9, 0x3113, 6, "EOS 30D"},
+ {0x04a9, 0x3114, 6, "EOS 30D (ptp)"},
+ {0x04a9, 0x311a, 4, "PowerShot S3 IS"},
++ {0x04a9, 0x3145, 6, "EOS 450D"},
++ {0x04a9, 0x3199, 6, "EOS 5D Mark II"},
+ {0, 0, 0, NULL}
+ };
+
diff --git a/graphics/multican/pkg-descr b/graphics/multican/pkg-descr
new file mode 100644
index 000000000000..49e10c29c35d
--- /dev/null
+++ b/graphics/multican/pkg-descr
@@ -0,0 +1,10 @@
+Multican is Canon EOS cameras USB remote control utility for 300D, 350D, 30D,
+20D, and 5D. Multican allows scripted remote control of multiple cameras; it
+is possible to control up to six cameras attached at the same time.
+
+Multican communicates with camera directly, without generic library such as
+provided by gPhoto2, and currently has no GUI, which makes it no replacement
+for Canon's EOS Utility, but it can be useful nonetheless in various setups,
+e.g. for astrophotography.
+
+WWW: http://multican.sourceforge.net/