aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/mupdf
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-11-12 00:38:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-11-12 00:38:48 +0800
commit083e28ce54285d7e79999ffc5ae9714a096d12b0 (patch)
tree45adc0538cf43bae0913b679731eddc3282e78bd /graphics/mupdf
parenta5a0ead578327c9134b097c75ddee6afa4ad2cea (diff)
downloadfreebsd-ports-gnome-083e28ce54285d7e79999ffc5ae9714a096d12b0.tar.gz
freebsd-ports-gnome-083e28ce54285d7e79999ffc5ae9714a096d12b0.tar.zst
freebsd-ports-gnome-083e28ce54285d7e79999ffc5ae9714a096d12b0.zip
MuPDF is a lightweight PDF viewer and toolkit written in portable C.
The renderer in MuPDF is tailored for high quality anti-aliased graphics. It renders text with metrics and spacing accurate to within fractions of a pixel for the highest fidelity in reproducing the look of a printed page on screen. MuPDF has a small footprint. A binary that includes the standard Roman fonts is only one megabyte. A build with full CJK support (including an Asian font) is approximately five megabytes. MuPDF has support for all non-interactive PDF 1.7 features, and the toolkit provides a simple API for accessing the internal structures of the PDF document. Example code for navigating interactive links and bookmarks, encrypting PDF files, extracting fonts, images, and searchable text, and rendering pages to image files is provided. WWW: http://ccxvii.net/mupdf/ PR: 137559 Submitted by: Martin Dieringer <martin.dieringer@gmx.de>
Diffstat (limited to 'graphics/mupdf')
-rw-r--r--graphics/mupdf/Makefile45
-rw-r--r--graphics/mupdf/distinfo3
-rw-r--r--graphics/mupdf/files/patch-Jamrules24
-rw-r--r--graphics/mupdf/pkg-descr18
-rw-r--r--graphics/mupdf/pkg-plist8
5 files changed, 98 insertions, 0 deletions
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
new file mode 100644
index 000000000000..1c2bf5979cb6
--- /dev/null
+++ b/graphics/mupdf/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mupdf
+# Date created: 2009-08-07
+# Whom: Martin Dieringer <martin.dieringer@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= mupdf
+DISTVERSION= 2009-07-07
+CATEGORIES= graphics
+MASTER_SITES= http://ccxvii.net/mupdf/download/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-source
+
+MAINTAINER= martin.dieringer@gmx.de
+COMMENT= Lightweight PDF viewer and toolkit
+
+BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
+ jpeg.10:${PORTSDIR}/graphics/jpeg
+
+USE_XORG= x11 xext
+JAM_ARGS= -q -sLOCALBASE=${LOCALBASE} \
+ -sPTHREAD_LIBS=${PTHREAD_LIBS} ${_MAKE_JOBS}
+MAKE_JOBS_SAFE= yes
+
+EXECUTABLES= cmapdump pdfdraw pdfinfo \
+ fontdump pdfclean pdfextract pdfshow
+
+OPTIONS= CJK "Enable Asian Fontset" On
+
+.include <bsd.port.options.mk>
+
+.if defined(WITHOUT_CJK)
+JAM_ARGS+= -sDEFINES=NOCJK
+.endif
+
+do-build:
+ cd ${WRKSRC} && jam ${JAM_ARGS}
+
+do-install:
+ ${INSTALL} ${WRKSRC}/build/mupdf ${PREFIX}/bin/mupdf
+.for f in ${EXECUTABLES}
+ ${INSTALL} ${WRKSRC}/build/$f ${PREFIX}/bin/mu_$f ;
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/mupdf/distinfo b/graphics/mupdf/distinfo
new file mode 100644
index 000000000000..d56e5cb1a94e
--- /dev/null
+++ b/graphics/mupdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (mupdf-2009-07-07-source.tar.gz) = 3b499c4f34909093bab308497f62eb5c
+SHA256 (mupdf-2009-07-07-source.tar.gz) = d3c252b4a1f98270235844e9d4507b3533f17981099a5c82531551634a34e4fe
+SIZE (mupdf-2009-07-07-source.tar.gz) = 3297517
diff --git a/graphics/mupdf/files/patch-Jamrules b/graphics/mupdf/files/patch-Jamrules
new file mode 100644
index 000000000000..825b0539999e
--- /dev/null
+++ b/graphics/mupdf/files/patch-Jamrules
@@ -0,0 +1,24 @@
+--- Jamrules.orig 2009-07-07 20:08:22.000000000 +0200
++++ Jamrules 2009-08-08 12:32:45.000000000 +0200
+@@ -47,16 +47,16 @@
+ if $(HAVE_JASPER) { DEFINES += HAVE_JASPER ; }
+ if $(HAVE_OPENJPEG) { DEFINES += HAVE_OPENJPEG ; }
+
+-if $(OS) = LINUX
++if $(OS) = FREEBSD
+ {
+- Echo Building for LINUX ;
++ Echo Building for FREEBSD ;
+
+ BUILD_X11APP = true ;
+
+- CCFLAGS = -Wall -std=gnu99 -I/usr/include/freetype2 ;
+- LINKFLAGS = -L/usr/X11R6/lib ;
++ CCFLAGS = -Wall -std=gnu99 -I$(LOCALBASE)/include/freetype2 -I$(LOCALBASE)/include/ ;
++ LINKFLAGS = -L$(LOCALBASE)/lib ;
+ LINKLIBS = -lfreetype -ljpeg -lz -lm ;
+- APPLINKLIBS = -lX11 -lXext -lpthread ;
++ APPLINKLIBS = -lX11 -lXext $(PTHREAD_LIBS) ;
+
+ if $(BUILD) = debug { OPTIM = -g -O0 -fno-inline ; }
+ if $(BUILD) = release { OPTIM = -O3 ; }
diff --git a/graphics/mupdf/pkg-descr b/graphics/mupdf/pkg-descr
new file mode 100644
index 000000000000..1a597db68b3e
--- /dev/null
+++ b/graphics/mupdf/pkg-descr
@@ -0,0 +1,18 @@
+MuPDF is a lightweight PDF viewer and toolkit written in portable C.
+
+The renderer in MuPDF is tailored for high quality anti-aliased graphics. It
+renders text with metrics and spacing accurate to within fractions of a
+pixel for the highest fidelity in reproducing the look of a printed page on
+screen.
+
+MuPDF has a small footprint. A binary that includes the standard Roman fonts
+is only one megabyte. A build with full CJK support (including an Asian
+font) is approximately five megabytes.
+
+MuPDF has support for all non-interactive PDF 1.7 features, and the toolkit
+provides a simple API for accessing the internal structures of the PDF
+document. Example code for navigating interactive links and bookmarks,
+encrypting PDF files, extracting fonts, images, and searchable text, and
+rendering pages to image files is provided.
+
+WWW: http://ccxvii.net/mupdf/
diff --git a/graphics/mupdf/pkg-plist b/graphics/mupdf/pkg-plist
new file mode 100644
index 000000000000..1303cc9cc139
--- /dev/null
+++ b/graphics/mupdf/pkg-plist
@@ -0,0 +1,8 @@
+bin/mupdf
+bin/mu_pdfshow
+bin/mu_pdfdraw
+bin/mu_pdfinfo
+bin/mu_cmapdump
+bin/mu_pdfextract
+bin/mu_pdfclean
+bin/mu_fontdump