aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/netpbm
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-01-27 03:33:02 +0800
committerdinoex <dinoex@FreeBSD.org>2004-01-27 03:33:02 +0800
commitac9a07b3c211d07b83c91f6fef86715c27e1b6ae (patch)
tree438e2846c6a85ea562d407fc41b0ebc7412c2377 /graphics/netpbm
parent9142e87a0f638baa4bb7087540cf08044e2ce537 (diff)
downloadfreebsd-ports-gnome-ac9a07b3c211d07b83c91f6fef86715c27e1b6ae.tar.gz
freebsd-ports-gnome-ac9a07b3c211d07b83c91f6fef86715c27e1b6ae.tar.zst
freebsd-ports-gnome-ac9a07b3c211d07b83c91f6fef86715c27e1b6ae.zip
- make CC aware
- Fix build with gcc295-alpha, by forcing -O0
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 59347e0df6d8..44a21fdf1bc9 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-MAKE_ENV= LN="${LN}" RANLIB="${RANLIB}"
+MAKE_ENV= CC="${CC}" LN="${LN}" RANLIB="${RANLIB}"
MAKEFILE= GNUmakefile
INSTALL_TARGET= install.bin install.lib install.data install-dev
INSTALLS_SHLIB= yes
@@ -38,6 +38,11 @@ MAN1= netpbm.1
# -O causes an ICE in converter/other/exif.c with gcc 3.3.3 on sparc64.
CFLAGS+= -O0
.endif
+.if ${ARCH} == "alpha"
+.if ${OSVERSION} < 500000
+CFLAGS+= -O0
+.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \