aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/netpbm
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-12-22 05:40:05 +0800
committerdinoex <dinoex@FreeBSD.org>2003-12-22 05:40:05 +0800
commiteee1127e5061497f1c640e923fd958e08b465621 (patch)
tree628b441c9ad8428b174f764d9aa96a54c451309a /graphics/netpbm
parentb91daa6d6f8236216da0cbff27ac6bf73ae6b28f (diff)
downloadfreebsd-ports-gnome-eee1127e5061497f1c640e923fd958e08b465621.tar.gz
freebsd-ports-gnome-eee1127e5061497f1c640e923fd958e08b465621.tar.zst
freebsd-ports-gnome-eee1127e5061497f1c640e923fd958e08b465621.zip
- add patch to fix anytopnm
Submitted by: ls+muttedfc91b3@gambit.com.ru
Diffstat (limited to 'graphics/netpbm')
-rw-r--r--graphics/netpbm/Makefile2
-rw-r--r--graphics/netpbm/files/patch-converter-other-anytopnm65
2 files changed, 66 insertions, 1 deletions
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index 62d6606a3c98..9a6837a897e3 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netpbm
PORTVERSION= 10.19
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/netpbm/files/patch-converter-other-anytopnm b/graphics/netpbm/files/patch-converter-other-anytopnm
new file mode 100644
index 000000000000..d340b0a99577
--- /dev/null
+++ b/graphics/netpbm/files/patch-converter-other-anytopnm
@@ -0,0 +1,65 @@
+--- converter/other/anytopnm Fri Sep 19 22:35:58 2003
++++ converter/other/anytopnm Sun Dec 21 18:17:25 2003
+@@ -11,7 +11,7 @@
+ # documentation. This software is provided "as is" without express or
+ # implied warranty.
+
+-function putInputIntoTempfile() {
++putInputIntoTempfile() {
+
+ # $1 is the input file specification
+ # $2 is the temporary file name
+@@ -46,7 +46,7 @@
+
+
+
+-function setMimeType() {
++setMimeType() {
+ # $1 is the file name
+
+ # Christos Zoulas's current 'file' (see Freshmeat) has the --mime option.
+@@ -64,7 +64,7 @@
+
+
+
+-function computeTypeFromMimeType () {
++computeTypeFromMimeType() {
+
+ # $1 is the mime type string
+
+@@ -100,7 +100,7 @@
+
+
+
+-function computeTypeFromTypeDescription () {
++computeTypeFromTypeDescription() {
+
+ # $1 is the full description from 'file' of the file type
+
+@@ -196,7 +196,7 @@
+
+
+
+-function computeTypeFromFilenameExtension () {
++computeTypeFromFilenameExtension() {
+ # $1 is the filename extension (".gif", etc.)
+
+ case "$1" in
+@@ -304,7 +304,7 @@
+
+
+
+-function determineType () {
++determineType() {
+
+ # $1 is the name of the file that contains the subject file's contents
+ # $2 is the mime type or "unknown"
+@@ -327,7 +327,7 @@
+
+
+
+-function convertIt () {
++convertIt() {
+ # Based on the file type computed, do the conversion
+
+ # $1 is the input file name