aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocaml-images/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:35:06 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:35:06 +0800
commitf2e8639ee3b3f4e9e382a158b43f36876f3724f5 (patch)
treee65c2e7cf4a7b2114eb53c15eeb8702109dafaa1 /graphics/ocaml-images/Makefile
parentd252b8c59088431ca3dfc79efbffee22186a5992 (diff)
downloadfreebsd-ports-gnome-f2e8639ee3b3f4e9e382a158b43f36876f3724f5.tar.gz
freebsd-ports-gnome-f2e8639ee3b3f4e9e382a158b43f36876f3724f5.tar.zst
freebsd-ports-gnome-f2e8639ee3b3f4e9e382a158b43f36876f3724f5.zip
[PATCH] graphics/ocaml-images: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54930 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics/ocaml-images/Makefile')
-rw-r--r--graphics/ocaml-images/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index ade079c96883..6629140afa9f 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -18,12 +18,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Objective Caml image processing library
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
LIB_DEPENDS= ungif:${PORTSDIR}/graphics/libungif \
png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
@@ -37,4 +43,12 @@ CONFIGURE_ENV= \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
USE_GMAKE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
.include <bsd.port.mk>