aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocaml-lablgl/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-06-27 20:08:41 +0800
committerperky <perky@FreeBSD.org>2002-06-27 20:08:41 +0800
commitbdb62668bb07198d67a0fde67b4e290bcd49478a (patch)
tree9bd12c62cc790ef6c298d3b51b4e2bb428d3be7b /graphics/ocaml-lablgl/Makefile
parent3061d44576a4c58823474dbff46e9dda3fd035fa (diff)
downloadfreebsd-ports-gnome-bdb62668bb07198d67a0fde67b4e290bcd49478a.tar.gz
freebsd-ports-gnome-bdb62668bb07198d67a0fde67b4e290bcd49478a.tar.zst
freebsd-ports-gnome-bdb62668bb07198d67a0fde67b4e290bcd49478a.zip
Add lablgl 0.97, OpenGL interface for Objective Caml.
PR: 33961 Submitted by: Ronald Kuehn <rk@ronald.org>
Diffstat (limited to 'graphics/ocaml-lablgl/Makefile')
-rw-r--r--graphics/ocaml-lablgl/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
new file mode 100644
index 000000000000..43ac66dca8f3
--- /dev/null
+++ b/graphics/ocaml-lablgl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: lablgl
+# Date created: 13. January 2002
+# Whom: Ronald Kuehn <rk@ronald.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lablgl
+PORTVERSION= 0.97
+CATEGORIES= graphics
+MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
+ ftp://ftp.inria.fr/lang/caml-light/bazar-ocaml/
+
+MAINTAINER= rk@ronald.org
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
+
+USE_MESA= yes
+WRKSRC= ${WRKDIR}/lablGL-${PORTVERSION}
+ALL_TARGET= all opt
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+
+post-extract:
+ @${CP} ${WRKSRC}/Makefile.config.ex ${WRKSRC}/Makefile.config
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.if !defined(NO_PORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>