aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocaml-lablgl
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:35:26 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:35:26 +0800
commitae39fc48dcdf2a3d8613eb03f67731d1b6ad6001 (patch)
tree989dd8e1b1e6c8900e5268efdd3d75a25a3b7268 /graphics/ocaml-lablgl
parentc320816067bbebb0b0f197bcee87ac7785eb832c (diff)
downloadfreebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.tar.gz
freebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.tar.zst
freebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.zip
- adoption of optionsNG
- convert to USES in some cases (pkgconfig,pathfix) - trim COMMENT/historical headers in some cases Approved by: portmgr (miwi)
Diffstat (limited to 'graphics/ocaml-lablgl')
-rw-r--r--graphics/ocaml-lablgl/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index d88c42a0eba8..c0ca8973414a 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lablgl
-# Date created: 13. January 2002
-# Whom: Ronald Kuehn <rk@ronald.org>
-#
+# Created by: Ronald Kuehn <rk@ronald.org>
# $FreeBSD$
-#
PORTNAME= lablgl
PORTVERSION= 20120306
@@ -27,7 +23,10 @@ USE_OCAML_WASH= yes
ALL_TARGET= all opt
MAKE_JOBS_UNSAFE= yes
-OPTIONS= THREADS "Use a threaded Tcl/Tk (must match lang/ocaml)" on
+OPTIONS_DEFINE= THREADS
+THREADS_DESC= Threaded Tcl/Tk (must match lang/ocaml)
+
+OPTIONS_DEFAULT= THREADS
PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
@@ -36,11 +35,11 @@ EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/lablgl
CONFLICTS= ocaml-notk-[0-9]* ocaml-nox11-[0-9]*
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
USE_TK= 84+
INVALID_TK_VER = 86
-.if defined(WITH_THREADS)
+.if ${PORT_OPTIONS:MTHREADS}
THR_CPP= ${PTHREAD_CFLAGS}
THR_LD = ${PTHREAD_LIBS}
.endif
@@ -88,9 +87,9 @@ post-install:
${EXAMPLESDIR}/lablglut '! -name Makefile')
@(cd ${WRKSRC}/Togl/examples && ${COPYTREE_SHARE} \* \
${EXAMPLESDIR}/togl '! -name Makefile')
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>