aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocrad/Makefile
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2003-11-21 05:30:40 +0800
committersergei <sergei@FreeBSD.org>2003-11-21 05:30:40 +0800
commite04f73821aa24cffc5c40117cb6bd06fba174c57 (patch)
tree884ebb1eca363bb490ca30b194d0b9c41d805adf /graphics/ocrad/Makefile
parente54ccfdb7581bd5063a743d96f581fe4a16c6103 (diff)
downloadfreebsd-ports-gnome-e04f73821aa24cffc5c40117cb6bd06fba174c57.tar.gz
freebsd-ports-gnome-e04f73821aa24cffc5c40117cb6bd06fba174c57.tar.zst
freebsd-ports-gnome-e04f73821aa24cffc5c40117cb6bd06fba174c57.zip
Add ocrad 0.5, OCR program implemented as filter.
GNU Ocrad is an OCR (Optical Character Recognition) program implemented as a filter and based on a feature extraction method. It reads a bitmap image in pbm format and outputs text in ISO-8859-1 (Latin-1) charset. Also includes a layout analyser able to separate the columns or blocks of text normally found on printed pages. It can be used as a stand-alone console application, or as a backend to other programs. PR: 59232 Submitted by: Ulrich Spoerlein <q@uni.de>
Diffstat (limited to 'graphics/ocrad/Makefile')
-rw-r--r--graphics/ocrad/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/ocrad/Makefile b/graphics/ocrad/Makefile
new file mode 100644
index 000000000000..29d747d48b03
--- /dev/null
+++ b/graphics/ocrad/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: graphics/ocrad
+# Date created: 12.11.2003
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocrad
+PORTVERSION= 0.5
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= q@uni.de
+COMMENT= OCR program implemented as filter
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX}
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+DOCS= AUTHORS ChangeLog NEWS README TODO
+INFO= ocrad
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>