aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ocropus
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
committerade <ade@FreeBSD.org>2010-09-16 02:35:24 +0800
commit3ad75a4581c2f69fb2331ab72fee36ff8af166ba (patch)
treeb5ab9adb45e9a850892479ebc329ab2118d673c8 /graphics/ocropus
parentf72275e68db56a5d187d3a748951a6347a5ace60 (diff)
downloadfreebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.gz
freebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.tar.zst
freebsd-ports-gnome-3ad75a4581c2f69fb2331ab72fee36ff8af166ba.zip
Autotools update. Read ports/UPDATING 20100915 for details.
Approved by: portmgr (for Mk/bsd.port.mk part) Tested by: Multiple -exp runs
Diffstat (limited to 'graphics/ocropus')
-rw-r--r--graphics/ocropus/Makefile4
-rw-r--r--graphics/ocropus/files/patch-configure.ac32
2 files changed, 20 insertions, 16 deletions
diff --git a/graphics/ocropus/Makefile b/graphics/ocropus/Makefile
index c1c588a81a8c..1f4c5585570a 100644
--- a/graphics/ocropus/Makefile
+++ b/graphics/ocropus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ocropus
PORTVERSION= 0.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -27,7 +27,7 @@ OPTIONS= SDL "Enable SDL for graphical debugging" off \
MAKE_JOBS_UNSAFE= yes
USE_PYTHON_BUILD= yes
-USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:267
USE_GMAKE= yes
CONFIGURE_ARGS= --without-fst --without-tesseract --with-iulib=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
diff --git a/graphics/ocropus/files/patch-configure.ac b/graphics/ocropus/files/patch-configure.ac
index 49821662f843..a0d4abb730db 100644
--- a/graphics/ocropus/files/patch-configure.ac
+++ b/graphics/ocropus/files/patch-configure.ac
@@ -1,27 +1,31 @@
--- ./configure.ac.orig 2009-06-01 05:18:41.000000000 +0900
-+++ ./configure.ac 2009-06-17 19:47:20.000000000 +0900
-@@ -114,11 +114,19 @@
- AC_MSG_ERROR([no TIFFOpen; please install libtiff4-dev or equivalent]))
++++ ./configure.ac 2010-02-02 21:28:54.000000000 +0900
+@@ -115,13 +115,20 @@
AC_LANG_CPLUSPLUS
-+# should require CXXCPP before conditional AC_CHECK_HEADER
-+AC_PROG_CXXCPP
++# Unconditional AC_CHECK_LIB should be done before conditional ones.
++# --- libpthread (needed by tesseract) ---
++AC_CHECK_LIB(pthread, pthread_create,,)
++
# --- iulib (required) ---
# NB: we can only use functions with C linkage here
AC_CHECK_LIB(iulib, exit,,
- AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(avcodec, avcodec_open, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(avformat, url_fopen, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(iulib, sleep, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
+-
+-# --- libpthread (needed by tesseract) ---
+-AC_CHECK_LIB(pthread, pthread_create,,)
++ AC_CHECK_LIB([avcodec], [avcodec_open], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
++ AC_CHECK_LIB([avformat], [url_fopen], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
++ AC_CHECK_LIB([iulib], [sleep], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
+)
- # --- libpthread (needed by tesseract) ---
- AC_CHECK_LIB(pthread, pthread_create,,)
-@@ -176,14 +184,14 @@
+ # --- libtesseract (ahouls become optional) ---
+ if test x$notesseract != x1; then
+@@ -176,14 +183,14 @@
LDFLAGS="$LDFLAGS -L$leptheaders/../../lib"
AC_CHECK_LIB(lept,pixCreate,,AC_MSG_ERROR([leptonica not found! Choose --without-leptonica if you don't want to use it.]))
fi