aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2013-08-07 18:38:16 +0800
committeroliver <oliver@FreeBSD.org>2013-08-07 18:38:16 +0800
commit3af04c2c9009a133b823ad2a4767743a0fea5742 (patch)
treea6d555b0df0783d8019615a38517d856a0981459 /graphics/ogre3d
parentcdceccf63f1a145e1452447a9a035d2dce647670 (diff)
downloadfreebsd-ports-gnome-3af04c2c9009a133b823ad2a4767743a0fea5742.tar.gz
freebsd-ports-gnome-3af04c2c9009a133b823ad2a4767743a0fea5742.tar.zst
freebsd-ports-gnome-3af04c2c9009a133b823ad2a4767743a0fea5742.zip
fix clang detection
PR: ports/180092 Submitted by: tijl
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile4
-rw-r--r--graphics/ogre3d/files/patch-CMake_ConfigureBuild.cmake14
2 files changed, 9 insertions, 9 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index b527f17f17b2..e52bb6961bcc 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -39,10 +39,6 @@ PLIST_SUB+= BOOSTFALSE=""
BROKEN= Does not install on powerpc
.endif
-.if ${CXX:M*clang*}
-CMAKE_ARGS+= -DCMAKE_COMPILER_IS_GNUCXX:BOOL=YES
-.endif
-
post-patch:
.if ! ${PORT_OPTIONS:MBOOST}
@${REINPLACE_CMD} -e 's|Boost|No_Boost|g' \
diff --git a/graphics/ogre3d/files/patch-CMake_ConfigureBuild.cmake b/graphics/ogre3d/files/patch-CMake_ConfigureBuild.cmake
index 217dc242d2cc..29787a1ab0f0 100644
--- a/graphics/ogre3d/files/patch-CMake_ConfigureBuild.cmake
+++ b/graphics/ogre3d/files/patch-CMake_ConfigureBuild.cmake
@@ -1,6 +1,6 @@
---- CMake/ConfigureBuild.cmake.orig 2011-08-21 00:23:58.000000000 +0200
-+++ CMake/ConfigureBuild.cmake 2011-08-21 00:25:02.000000000 +0200
-@@ -180,18 +180,18 @@ if (UNIX)
+--- CMake/ConfigureBuild.cmake.orig 2012-09-02 07:27:14.000000000 +0200
++++ CMake/ConfigureBuild.cmake 2013-06-15 16:28:56.000000000 +0200
+@@ -189,18 +189,18 @@ if (UNIX)
else ()
configure_file(${OGRE_TEMPLATES_DIR}/OGRE.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE.pc @ONLY)
endif ()
@@ -22,7 +22,7 @@
endif ()
if (OGRE_BUILD_COMPONENT_TERRAIN)
-@@ -199,17 +199,17 @@ if (UNIX)
+@@ -208,20 +208,20 @@ if (UNIX)
set(OGRE_PAGING_ADDITIONAL_PACKAGES ", OGRE-Paging = ${OGRE_VERSION}")
endif ()
configure_file(${OGRE_TEMPLATES_DIR}/OGRE-Terrain.pc.in ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Terrain.pc @ONLY)
@@ -42,4 +42,8 @@
+ install(FILES ${OGRE_BINARY_DIR}/pkgconfig/OGRE-Property.pc DESTINATION ${OGRE_LIBDATA_DIRECTORY}/pkgconfig)
endif ()
- endif ()
+- if (CMAKE_CXX_COMPILER MATCHES ".*clang")
++ if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
+ set(CMAKE_COMPILER_IS_CLANGXX 1)
+ endif ()
+