aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2011-04-29 13:54:39 +0800
committeroliver <oliver@FreeBSD.org>2011-04-29 13:54:39 +0800
commite878db0e6f391b286caa77e5af70332a9e461f63 (patch)
treed103b6d5a526c0fff43a59d1bac56a50ea50a1b9 /graphics/ogre3d
parentebee452fae26a9fc6a16c274a7e94b775793f8b0 (diff)
downloadfreebsd-ports-gnome-e878db0e6f391b286caa77e5af70332a9e461f63.tar.gz
freebsd-ports-gnome-e878db0e6f391b286caa77e5af70332a9e461f63.tar.zst
freebsd-ports-gnome-e878db0e6f391b286caa77e5af70332a9e461f63.zip
add a dependency to freeimage to allow building of games/ember 0.6.1
PORTREVISION bumped
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile4
-rw-r--r--graphics/ogre3d/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index de38bc419ace..5d0ead4ba74f 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ogre3d
PORTVERSION= 1.7.2
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= SF/ogre/ogre/${PORTVERSION:C/.[0-9]$//g}
DISTNAME= ogre_src_v${PORTVERSION:S/./-/g}
@@ -15,7 +16,8 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= A scene-oriented, flexible 3D engine written in C++
LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ freeimage.3:${PORTSDIR}/graphics/freeimage
USE_LDCONFIG= YES
USE_BZIP2= YES
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index 12ef8cf90f61..b40c0fde2c11 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -66,6 +66,7 @@ include/OGRE/OgreFileSystem.h
include/OGRE/OgreFont.h
include/OGRE/OgreFontManager.h
include/OGRE/OgreFrameListener.h
+include/OGRE/OgreFreeImageCodec.h
include/OGRE/OgreFrustum.h
include/OGRE/OgreGpuProgram.h
include/OGRE/OgreGpuProgramManager.h