aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/opendis/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2002-01-15 05:49:24 +0800
committerjim <jim@FreeBSD.org>2002-01-15 05:49:24 +0800
commitcb63f3ab4a5d83d6674f14b2faf5e4185c88f2ee (patch)
tree71abd10e1d9f9836d7de096c1f552da6ea3f1850 /graphics/opendis/Makefile
parentad3077f579929fdd54e4d8a23505929a60da8bdf (diff)
downloadfreebsd-ports-gnome-cb63f3ab4a5d83d6674f14b2faf5e4185c88f2ee.tar.gz
freebsd-ports-gnome-cb63f3ab4a5d83d6674f14b2faf5e4185c88f2ee.tar.zst
freebsd-ports-gnome-cb63f3ab4a5d83d6674f14b2faf5e4185c88f2ee.zip
Fix MASTER_SITES, respect CFLAGS, remove unnecessary USE_AUTOCONF.
PR: 33883 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'graphics/opendis/Makefile')
-rw-r--r--graphics/opendis/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/graphics/opendis/Makefile b/graphics/opendis/Makefile
index 1496eb90e9f5..6d3251ef6c6b 100644
--- a/graphics/opendis/Makefile
+++ b/graphics/opendis/Makefile
@@ -7,24 +7,25 @@
PORTNAME= opendis
PORTVERSION= 0.0.3
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://ods.sourceforge.net/dl/ \
- ftp://ftp.nuug.no/pub/anders/distfiles/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://ods.sourceforge.net/dl/
+MASTER_SITE_SUBDIR= ods
MAINTAINER= ports@FreeBSD.org
-USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
-DOCS= NEWS AUTHORS doc/ERRATA doc/PHILOSOPHY doc/THUMB
+post-patch:
+ @${PERL} -pi -e 's|-pedantic -W|-pedantic|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's| -g| \@CFLAGS\@|g' ${WRKSRC}/src/Makefile.in
-.if !defined(NOPORTDOCS)
post-install:
- @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in NEWS AUTHORS doc/ERRATA doc/PHILOSOPHY doc/THUMB
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif