aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/opendx/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-03-21 20:58:39 +0800
committertg <tg@FreeBSD.org>2001-03-21 20:58:39 +0800
commit8d708cbc2159b74a1cc05aaa479a1c549e39214e (patch)
treec08bbf5652113603dac8f36326f07c61e1dee310 /graphics/opendx/Makefile
parent156af135cd4a6a8829a888cb77986bd29d81f7cb (diff)
downloadfreebsd-ports-gnome-8d708cbc2159b74a1cc05aaa479a1c549e39214e.tar.gz
freebsd-ports-gnome-8d708cbc2159b74a1cc05aaa479a1c549e39214e.tar.zst
freebsd-ports-gnome-8d708cbc2159b74a1cc05aaa479a1c549e39214e.zip
- Remove `-lcompat' again, the new patches contain code fixes.
- Fix paths in the documentation (/usr/lpp -> ${PREFIX}). - patch-ae is no longer needed with gmake.
Diffstat (limited to 'graphics/opendx/Makefile')
-rw-r--r--graphics/opendx/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index e2bbf5117fbf..ba4c95b267d5 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -37,14 +37,18 @@ CONFIGURE_ENV= ARCH="" \
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
-# XXX the -lcompat below is an ugly kludge. opendx's code
-# should be fixed to use the modern POSIX style regcomp(3)
-# instead of the old V8 style one.
post-patch:
@find ${WRKSRC} -name Makefile.am | \
- xargs ${PERL} -pi -e "s;-lXm ;-lcompat ${MOTIFLIB} ;g"
+ xargs ${PERL} -pi -e "s;-lXm ;${MOTIFLIB} ;g"
pre-configure:
- @cd ${WRKSRC} && aclocal
+ @cd ${WRKSRC} && aclocal && ${SETENV} ${CONFIGURE_ENV} autoheader
+
+post-install:
+ @${ECHO_MSG} "===> Fixing path in the docs (/usr/lpp -> ${PREFIX})"
+.for dir in doc help html man
+ @find ${PREFIX}/dx/${dir} -type f | \
+ xargs ${PERL} -pi -e "s;/usr/lpp;${PREFIX};g"
+.endfor
.include <bsd.port.mk>