aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/opendx
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-09-02 00:07:59 +0800
commitfd50192ea7567a034b59dfc96a1d112f8ccfa573 (patch)
tree6975c46330f04e77b17cb4d014c9d66ceb4f7a68 /graphics/opendx
parent54d69c112debb52b84b6d174bd59479eec834fb7 (diff)
downloadfreebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.gz
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.tar.zst
freebsd-ports-gnome-fd50192ea7567a034b59dfc96a1d112f8ccfa573.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 38bbe99de1a9..4b2f80a3cc18 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -27,6 +27,7 @@ USE_GMAKE= yes
USE_MESA= yes
USE_MOTIF= yes
USE_XLIB= yes
+USE_REINPLACE= yes
AUTOMAKE_ARGS= -a -i
GNU_CONFIGURE= yes
CONFIGURE_ENV= ARCH="" \
@@ -41,13 +42,13 @@ post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
post-configure:
- ${PERL} -pi -e "s;flex ;flex -l ;g" ${WRKSRC}/src/uipp/dxuilib/Makefile
+ ${REINPLACE_CMD} -e "s;flex ;flex -l ;g" ${WRKSRC}/src/uipp/dxuilib/Makefile
post-install:
@${ECHO_MSG} "===> Fixing path in the docs (/usr/lpp -> ${PREFIX})"
.for dir in doc help html man
- @find ${PREFIX}/dx/${dir} -type f | \
- xargs ${PERL} -pi -e "s;/usr/lpp;${PREFIX};g"
+ @${FIND} ${PREFIX}/dx/${dir} -type f | \
+ ${XARGS} ${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
.endfor
.include <bsd.port.mk>