aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/openjpeg
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-14 05:39:14 +0800
committermiwi <miwi@FreeBSD.org>2007-01-14 05:39:14 +0800
commit74d992917b2ceeb1318b547482756dc3cad7d0f1 (patch)
tree46f1b72bfaa7387a08914936463b5bab22a1344d /graphics/openjpeg
parent78f958d7c71d8889510938f10be444f3d01bcaa2 (diff)
downloadfreebsd-ports-gnome-74d992917b2ceeb1318b547482756dc3cad7d0f1.tar.gz
freebsd-ports-gnome-74d992917b2ceeb1318b547482756dc3cad7d0f1.tar.zst
freebsd-ports-gnome-74d992917b2ceeb1318b547482756dc3cad7d0f1.zip
The OpenJPEG library is an open-source JPEG 2000 codec written in
C language. It has been developed in order to promote the use of JPEG 2000, the new still-image compression standard from the Joint Photographic Experts Group (JPEG). In addition to the basic codec, various other features are under development, among them the JP2 and MJ2 (Motion JPEG 2000) file formats, an indexing tool useful for the JPIP protocol, JPWL-tools for error-resilience, a Java-viewer for j2k-images, ... WWW: http://www.openjpeg.org/ PR: ports/107868 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Diffstat (limited to 'graphics/openjpeg')
-rw-r--r--graphics/openjpeg/Makefile23
-rw-r--r--graphics/openjpeg/distinfo3
-rw-r--r--graphics/openjpeg/files/patch-Makefile33
-rw-r--r--graphics/openjpeg/pkg-descr10
4 files changed, 69 insertions, 0 deletions
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
new file mode 100644
index 000000000000..64c455595cf6
--- /dev/null
+++ b/graphics/openjpeg/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: openjpeg
+# Date created: 2007-01-13
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openjpeg
+PORTVERSION= 1.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.openjpeg.org/
+DISTNAME= openjpeg_v1_1
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= An open-source JPEG 2000 codec
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/OpenJPEG/
+PLIST_FILES= lib/libopenjpeg.a lib/libopenjpeg-1.0.0.so lib/libopenjpeg.so.1
+
+.include <bsd.port.mk>
diff --git a/graphics/openjpeg/distinfo b/graphics/openjpeg/distinfo
new file mode 100644
index 000000000000..5608f36f63e6
--- /dev/null
+++ b/graphics/openjpeg/distinfo
@@ -0,0 +1,3 @@
+MD5 (openjpeg_v1_1.tar.gz) = 6bf7768d7a37b25b13994f455760ef90
+SHA256 (openjpeg_v1_1.tar.gz) = 71ddea3b8adea46c7c71502887501b28a631ec36d321f40cf214f22365208c3b
+SIZE (openjpeg_v1_1.tar.gz) = 1419311
diff --git a/graphics/openjpeg/files/patch-Makefile b/graphics/openjpeg/files/patch-Makefile
new file mode 100644
index 000000000000..ee94d2b8a7e0
--- /dev/null
+++ b/graphics/openjpeg/files/patch-Makefile
@@ -0,0 +1,33 @@
+--- Makefile.orig Wed Feb 1 22:25:11 2006
++++ Makefile Sat Jan 13 12:52:47 2007
+@@ -8,15 +8,13 @@
+ INCLUDE = -Ilibopenjpeg
+
+ # General configuration variables:
+-CC = gcc
+-AR = ar
+
+-INSTALLDIR = /usr/lib
++INSTALLDIR = $(PREFIX)/lib
+
+ # Converts cr/lf to just lf
+ DOS2UNIX = dos2unix
+
+-COMPILERFLAGS = -O3
++COMPILERFLAGS := $(CFLAGS)
+ LIBRARIES = -lstdc++
+
+ MODULES = $(SRCS:.c=.o)
+@@ -54,10 +52,9 @@
+ $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
+
+ install:
+- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
+- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
++ install -m 644 -o 0 -g 0 $(STATICLIB) $(INSTALLDIR)
++ install -m 755 -o 0 -g 0 $(SHAREDLIB) $(INSTALLDIR)
+ ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(LIBNAME)
+- ldconfig
+
+ clean:
+ rm -rf core dist/ u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/graphics/openjpeg/pkg-descr b/graphics/openjpeg/pkg-descr
new file mode 100644
index 000000000000..b23d3e6cc96e
--- /dev/null
+++ b/graphics/openjpeg/pkg-descr
@@ -0,0 +1,10 @@
+The OpenJPEG library is an open-source JPEG 2000 codec written in
+C language. It has been developed in order to promote the use of
+JPEG 2000, the new still-image compression standard from the Joint
+Photographic Experts Group (JPEG). In addition to the basic codec,
+various other features are under development, among them the JP2
+and MJ2 (Motion JPEG 2000) file formats, an indexing tool useful
+for the JPIP protocol, JPWL-tools for error-resilience, a Java-viewer
+for j2k-images, ...
+
+WWW: http://www.openjpeg.org/