aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Cairo
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /graphics/p5-Cairo
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'graphics/p5-Cairo')
-rw-r--r--graphics/p5-Cairo/Makefile1
-rw-r--r--graphics/p5-Cairo/pkg-plist17
2 files changed, 9 insertions, 9 deletions
diff --git a/graphics/p5-Cairo/Makefile b/graphics/p5-Cairo/Makefile
index 498863ec48d2..450b96700d0c 100644
--- a/graphics/p5-Cairo/Makefile
+++ b/graphics/p5-Cairo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Cairo
PORTVERSION= 1.104
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN \
SF/gtk2-perl/${PORTNAME}/${PORTVERSION}
diff --git a/graphics/p5-Cairo/pkg-plist b/graphics/p5-Cairo/pkg-plist
index 7b073398f3e5..195e623c1d0f 100644
--- a/graphics/p5-Cairo/pkg-plist
+++ b/graphics/p5-Cairo/pkg-plist
@@ -1,10 +1,9 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/Files.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/cairo-perl-auto.h
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/cairo-perl-auto.typemap
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/cairo-perl.h
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/cairo-perl.typemap
-%%SITE_PERL%%/%%PERL_ARCH%%/Cairo/Install/doctypes
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cairo/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cairo/Cairo.so
+%%SITE_ARCH%%/Cairo.pm
+%%SITE_ARCH%%/Cairo/Install/Files.pm
+%%SITE_ARCH%%/Cairo/Install/cairo-perl-auto.h
+%%SITE_ARCH%%/Cairo/Install/cairo-perl-auto.typemap
+%%SITE_ARCH%%/Cairo/Install/cairo-perl.h
+%%SITE_ARCH%%/Cairo/Install/cairo-perl.typemap
+%%SITE_ARCH%%/Cairo/Install/doctypes
+%%SITE_ARCH%%/auto/Cairo/Cairo.so
%%PERL5_MAN3%%/Cairo.3.gz