aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Chart-Clicker
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-23 21:42:30 +0800
committermiwi <miwi@FreeBSD.org>2006-08-23 21:42:30 +0800
commit601f761ededa54a707391d0dc34dbca0c6fc4626 (patch)
tree08f7f4da5154bf2cf7557f6f3544cc7a5a15223c /graphics/p5-Chart-Clicker
parent342d6c8a0bef4d2b7bb6b0bc2105a72ee6987498 (diff)
downloadfreebsd-ports-gnome-601f761ededa54a707391d0dc34dbca0c6fc4626.tar.gz
freebsd-ports-gnome-601f761ededa54a707391d0dc34dbca0c6fc4626.tar.zst
freebsd-ports-gnome-601f761ededa54a707391d0dc34dbca0c6fc4626.zip
hart::Clicker aims to be a powerful, extensible charting package that
creates really pretty output. Clicker leverages the power of Cairo to create snazzy 2D graphics easily and quickly. At it's core Clicker is more of a toolkit for creating charts. It's interface is a bit more complex because making pretty charts requires attention and care. Some fine defaults are established to make getting started easier, but to really unleash the potential of Clicker you must roll up your sleeves and build things by hand. WWW: http://search.cpan.org/dist/Chart-Clicker/ PR: ports/102070 Submitted by: chinsan <chinsan.tw(at)gmail.com> Approved by: krion (mentor)
Diffstat (limited to 'graphics/p5-Chart-Clicker')
-rw-r--r--graphics/p5-Chart-Clicker/Makefile53
-rw-r--r--graphics/p5-Chart-Clicker/distinfo3
-rw-r--r--graphics/p5-Chart-Clicker/pkg-descr13
-rw-r--r--graphics/p5-Chart-Clicker/pkg-plist44
4 files changed, 113 insertions, 0 deletions
diff --git a/graphics/p5-Chart-Clicker/Makefile b/graphics/p5-Chart-Clicker/Makefile
new file mode 100644
index 000000000000..2084fc72d46c
--- /dev/null
+++ b/graphics/p5-Chart-Clicker/Makefile
@@ -0,0 +1,53 @@
+# Ports collection makefile for: Chart-Clicker
+# Date created: 2006/08/15
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chart-Clicker
+PORTVERSION= 1.0.2
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/G/GP/GPHAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Powerful, extensible charting
+
+BUILD_DEPENDS= p5-Class-Accessor>=0.25:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Cairo>=0.03:${PORTSDIR}/graphics/p5-Cairo
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Chart::Clicker.3 Chart::Clicker::Axis.3 \
+ Chart::Clicker::Data::DataSet.3 Chart::Clicker::Data::Range.3 \
+ Chart::Clicker::Data::Series.3 \
+ Chart::Clicker::Decoration::Base.3 \
+ Chart::Clicker::Decoration::Grid.3 \
+ Chart::Clicker::Decoration::Label.3 \
+ Chart::Clicker::Decoration::Legend.3 \
+ Chart::Clicker::Decoration::LegendItem.3 \
+ Chart::Clicker::Decoration::Marker.3 \
+ Chart::Clicker::Decoration::Plot.3 Chart::Clicker::Drawing.3 \
+ Chart::Clicker::Drawing::Border.3 \
+ Chart::Clicker::Drawing::Color.3 \
+ Chart::Clicker::Drawing::ColorAllocator.3 \
+ Chart::Clicker::Drawing::Component.3 \
+ Chart::Clicker::Drawing::Container.3 \
+ Chart::Clicker::Drawing::Dimension.3 \
+ Chart::Clicker::Drawing::Font.3 \
+ Chart::Clicker::Drawing::Insets.3 \
+ Chart::Clicker::Drawing::Point.3 \
+ Chart::Clicker::Drawing::Stroke.3 \
+ Chart::Clicker::Renderer::Area.3 \
+ Chart::Clicker::Renderer::Bar.3 \
+ Chart::Clicker::Renderer::Base.3 \
+ Chart::Clicker::Renderer::Line.3 \
+ Chart::Clicker::Renderer::Marker.3 \
+ Chart::Clicker::Renderer::Point.3 \
+ Chart::Clicker::Shape.3 Chart::Clicker::Shape::Arc.3 \
+ Chart::Clicker::Shape::Rectangle.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Chart-Clicker/distinfo b/graphics/p5-Chart-Clicker/distinfo
new file mode 100644
index 000000000000..0663de8d02f6
--- /dev/null
+++ b/graphics/p5-Chart-Clicker/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chart-Clicker-1.0.2.tar.gz) = 4d7146714c9b7c50544a7e940cca0a6f
+SHA256 (Chart-Clicker-1.0.2.tar.gz) = 096998b0c36f97ac8c6ce2c2ef893c46c873e504a69ea1c85cf8234c554a5511
+SIZE (Chart-Clicker-1.0.2.tar.gz) = 34081
diff --git a/graphics/p5-Chart-Clicker/pkg-descr b/graphics/p5-Chart-Clicker/pkg-descr
new file mode 100644
index 000000000000..d3d81fd52ef1
--- /dev/null
+++ b/graphics/p5-Chart-Clicker/pkg-descr
@@ -0,0 +1,13 @@
+Chart::Clicker aims to be a powerful, extensible charting package that
+creates really pretty output.
+
+Clicker leverages the power of Cairo to create snazzy 2D graphics easily and
+quickly.
+
+At it's core Clicker is more of a toolkit for creating charts. It's
+interface is a bit more complex because making pretty charts requires
+attention and care. Some fine defaults are established to make getting
+started easier, but to really unleash the potential of Clicker you must roll
+up your sleeves and build things by hand.
+
+WWW: http://search.cpan.org/dist/Chart-Clicker/
diff --git a/graphics/p5-Chart-Clicker/pkg-plist b/graphics/p5-Chart-Clicker/pkg-plist
new file mode 100644
index 000000000000..b7c78abc507f
--- /dev/null
+++ b/graphics/p5-Chart-Clicker/pkg-plist
@@ -0,0 +1,44 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Clicker/.packlist
+%%SITE_PERL%%/Chart/Clicker.pm
+%%SITE_PERL%%/Chart/document.pl
+%%SITE_PERL%%/Chart/critique.pl
+%%SITE_PERL%%/Chart/Clicker/Drawing.pm
+%%SITE_PERL%%/Chart/Clicker/Axis.pm
+%%SITE_PERL%%/Chart/Clicker/Shape.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Point.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Base.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Area.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Marker.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Bar.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer/Line.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Insets.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Container.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Border.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Stroke.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Component.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Point.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Font.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/ColorAllocator.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Color.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/Dimension.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Grid.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Base.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Label.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Legend.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/LegendItem.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Plot.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Marker.pm
+%%SITE_PERL%%/Chart/Clicker/Shape/Rectangle.pm
+%%SITE_PERL%%/Chart/Clicker/Shape/Arc.pm
+%%SITE_PERL%%/Chart/Clicker/Data/DataSet.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Series.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Range.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Clicker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Shape
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Renderer
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Drawing
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Decoration
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Data
+@dirrmtry %%SITE_PERL%%/Chart/Clicker
+@dirrmtry %%SITE_PERL%%/Chart