aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Gimp
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /graphics/p5-Gimp
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'graphics/p5-Gimp')
-rw-r--r--graphics/p5-Gimp/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/p5-Gimp/Makefile b/graphics/p5-Gimp/Makefile
index 384317b56a88..15b9f7deabd5 100644
--- a/graphics/p5-Gimp/Makefile
+++ b/graphics/p5-Gimp/Makefile
@@ -15,13 +15,13 @@ LICENSE= ART10 GPLv1
LICENSE_COMB= dual
RUN_DEPENDS= p5-Gtk2>=1.0:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
- PDL>=2.007:${PORTSDIR}/math/PDL \
- p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
p5-Gtk2-Ex-PodViewer>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-PodViewer \
+ p5-IO-All>=0:${PORTSDIR}/devel/p5-IO-All \
p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
p5-Web-Scraper>=0:${PORTSDIR}/www/p5-Web-Scraper \
- p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
-BUILD_DEPENDS= p5-ExtUtils-Depends>=0.200:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ PDL>=2.007:${PORTSDIR}/math/PDL
+BUILD_DEPENDS:= p5-ExtUtils-Depends>=0.200:${PORTSDIR}/devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
${RUN_DEPENDS}
LIB_DEPENDS= libgimp-2.0.so:${PORTSDIR}/graphics/gimp-app