aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Graph-Easy
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-10-22 17:22:07 +0800
committertobez <tobez@FreeBSD.org>2005-10-22 17:22:07 +0800
commit57db491ffbab6cfe897d25f244aa7ee2a5bfdb9b (patch)
tree418cf4fb2efe9f0d76164c73ee5eb9d6ee57f6f4 /graphics/p5-Graph-Easy
parent07ebaf9bd70707ab6a5573e8e2e07f650339aa8c (diff)
downloadfreebsd-ports-gnome-57db491ffbab6cfe897d25f244aa7ee2a5bfdb9b.tar.gz
freebsd-ports-gnome-57db491ffbab6cfe897d25f244aa7ee2a5bfdb9b.tar.zst
freebsd-ports-gnome-57db491ffbab6cfe897d25f244aa7ee2a5bfdb9b.zip
Add graphics/p5-Graph-Easy, a Perl module to render graphs as ASCII,
HTML, SVG or Graphviz.
Diffstat (limited to 'graphics/p5-Graph-Easy')
-rw-r--r--graphics/p5-Graph-Easy/Makefile48
-rw-r--r--graphics/p5-Graph-Easy/distinfo2
-rw-r--r--graphics/p5-Graph-Easy/pkg-descr4
-rw-r--r--graphics/p5-Graph-Easy/pkg-plist26
4 files changed, 80 insertions, 0 deletions
diff --git a/graphics/p5-Graph-Easy/Makefile b/graphics/p5-Graph-Easy/Makefile
new file mode 100644
index 000000000000..69de63d07532
--- /dev/null
+++ b/graphics/p5-Graph-Easy/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: graphics/p5-Graph-Easy
+# Date created: 22 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graph-Easy
+PORTVERSION= 0.30
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Graph
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Render graphs as ASCII, HTML, SVG or Graphviz
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Graph::Easy.3 \
+ Graph::Easy::As_ascii.3 \
+ Graph::Easy::As_graphviz.3 \
+ Graph::Easy::As_txt.3 \
+ Graph::Easy::Attributes.3 \
+ Graph::Easy::Edge.3 \
+ Graph::Easy::Edge::Cell.3 \
+ Graph::Easy::Group.3 \
+ Graph::Easy::Group::Cell.3 \
+ Graph::Easy::Layout.3 \
+ Graph::Easy::Layout::Path.3 \
+ Graph::Easy::Layout::Scout.3 \
+ Graph::Easy::Node.3 \
+ Graph::Easy::Node::Anon.3 \
+ Graph::Easy::Node::Cell.3 \
+ Graph::Easy::Node::Empty.3 \
+ Graph::Easy::Parser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Graph-Easy/distinfo b/graphics/p5-Graph-Easy/distinfo
new file mode 100644
index 000000000000..d89db87f24c4
--- /dev/null
+++ b/graphics/p5-Graph-Easy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Graph-Easy-0.30.tar.gz) = 70a6427a88d39451a8467060743acd43
+SIZE (Graph-Easy-0.30.tar.gz) = 145994
diff --git a/graphics/p5-Graph-Easy/pkg-descr b/graphics/p5-Graph-Easy/pkg-descr
new file mode 100644
index 000000000000..e1dca2bd0d84
--- /dev/null
+++ b/graphics/p5-Graph-Easy/pkg-descr
@@ -0,0 +1,4 @@
+Graph::Easy lets you generate graphs consisting of various shaped nodes
+connected by edges (with optional labels).
+
+WWW: http://search.cpan.org/dist/Graph-Easy/
diff --git a/graphics/p5-Graph-Easy/pkg-plist b/graphics/p5-Graph-Easy/pkg-plist
new file mode 100644
index 000000000000..ad64d091a352
--- /dev/null
+++ b/graphics/p5-Graph-Easy/pkg-plist
@@ -0,0 +1,26 @@
+%%SITE_PERL%%/Graph/Easy.pm
+%%SITE_PERL%%/Graph/Easy/As_ascii.pm
+%%SITE_PERL%%/Graph/Easy/As_graphviz.pm
+%%SITE_PERL%%/Graph/Easy/As_txt.pm
+%%SITE_PERL%%/Graph/Easy/Attributes.pm
+%%SITE_PERL%%/Graph/Easy/Edge.pm
+%%SITE_PERL%%/Graph/Easy/Edge/Cell.pm
+%%SITE_PERL%%/Graph/Easy/Group.pm
+%%SITE_PERL%%/Graph/Easy/Group/Cell.pm
+%%SITE_PERL%%/Graph/Easy/Layout.pm
+%%SITE_PERL%%/Graph/Easy/Layout/Path.pm
+%%SITE_PERL%%/Graph/Easy/Layout/Scout.pm
+%%SITE_PERL%%/Graph/Easy/Node.pm
+%%SITE_PERL%%/Graph/Easy/Node/Anon.pm
+%%SITE_PERL%%/Graph/Easy/Node/Cell.pm
+%%SITE_PERL%%/Graph/Easy/Node/Empty.pm
+%%SITE_PERL%%/Graph/Easy/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/Easy/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/Easy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph/Easy/Layout 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph/Easy/Group 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph/Easy/Node 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph/Easy/Edge 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph/Easy 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Graph 2>/dev/null || true