aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-SWF-Builder/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-03-24 00:06:07 +0800
committerskv <skv@FreeBSD.org>2004-03-24 00:06:07 +0800
commitf756f0f7cd9cb40a64808ce2aace887984aa0073 (patch)
treea02880234f7d7cf6ae001f9c207645f4dfae1175 /graphics/p5-SWF-Builder/Makefile
parent02efb00fc21a2ba1206bc9dcac030080a4980553 (diff)
downloadfreebsd-ports-gnome-f756f0f7cd9cb40a64808ce2aace887984aa0073.tar.gz
freebsd-ports-gnome-f756f0f7cd9cb40a64808ce2aace887984aa0073.tar.zst
freebsd-ports-gnome-f756f0f7cd9cb40a64808ce2aace887984aa0073.zip
Add p5-SWF-Builder 0.04, create SWF movie.
Diffstat (limited to 'graphics/p5-SWF-Builder/Makefile')
-rw-r--r--graphics/p5-SWF-Builder/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/graphics/p5-SWF-Builder/Makefile b/graphics/p5-SWF-Builder/Makefile
new file mode 100644
index 000000000000..b495ba0e7918
--- /dev/null
+++ b/graphics/p5-SWF-Builder/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: SWF-Builder
+# Date created: 25 December 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SWF-Builder
+PORTVERSION= 0.04
+CATEGORIES= graphics www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/Y/YS/YSAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Create SWF movie
+
+BUILD_DEPENDS= ${SITE_PERL}/SWF/Element.pm:${PORTSDIR}/graphics/p5-SWF-File \
+ ${SITE_PERL}/Font/TTF/Font.pm:${PORTSDIR}/x11-fonts/p5-Font-TTF
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SWF::Builder.3 SWF::Builder::ActionScript.3 \
+ SWF::Builder::Bitmap.3 SWF::Builder::Font.3 \
+ SWF::Builder::Gradient.3 SWF::Builder::MovieClip.3 \
+ SWF::Builder::Shape.3 SWF::Builder::Text.3
+MAN1= asc.plx.1
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f |\
+ ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>