aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/p5-Tk-JPEG-Lite/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-08-11 00:03:19 +0800
committervanilla <vanilla@FreeBSD.org>2004-08-11 00:03:19 +0800
commita551480cdf2a9ac7e1bd5cf4e88d0907cc4f5e1f (patch)
tree8cb9fa62354902b361e3379ff67dd6040b7d5fc6 /graphics/p5-Tk-JPEG-Lite/Makefile
parent35cbe36901cea4c99b2d7646443a072998f2b537 (diff)
downloadfreebsd-ports-gnome-a551480cdf2a9ac7e1bd5cf4e88d0907cc4f5e1f.tar.gz
freebsd-ports-gnome-a551480cdf2a9ac7e1bd5cf4e88d0907cc4f5e1f.tar.zst
freebsd-ports-gnome-a551480cdf2a9ac7e1bd5cf4e88d0907cc4f5e1f.zip
Add p5-Tk-JPEG-Lite 2.01403, very simplistic image viewer that loads
JPEG images. PR: ports/69503 Submitted by: Michael Johnson <ahze@ahze.net>
Diffstat (limited to 'graphics/p5-Tk-JPEG-Lite/Makefile')
-rw-r--r--graphics/p5-Tk-JPEG-Lite/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/p5-Tk-JPEG-Lite/Makefile b/graphics/p5-Tk-JPEG-Lite/Makefile
new file mode 100644
index 000000000000..ab5bc090675b
--- /dev/null
+++ b/graphics/p5-Tk-JPEG-Lite/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Tk-JPEG-Lite
+# Date created: 2004-07-23
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-JPEG-Lite
+PORTVERSION= 2.01403
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tk
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Very simplistic image viewer that loads JPEG images
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN1= tkjpeg.1
+MAN3= Tk::JPEG::Lite.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>