aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/passepartout/Makefile
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-09-25 23:20:36 +0800
committerbland <bland@FreeBSD.org>2003-09-25 23:20:36 +0800
commit488598ce39155276935b523179b4fe4e01f85335 (patch)
tree344c48f1cceaaeb1a462c6f4facf013ebb850c5b /graphics/passepartout/Makefile
parentb67649b6f3dab344d5ebcc5cb0c231e6d862df9e (diff)
downloadfreebsd-ports-gnome-488598ce39155276935b523179b4fe4e01f85335.tar.gz
freebsd-ports-gnome-488598ce39155276935b523179b4fe4e01f85335.tar.zst
freebsd-ports-gnome-488598ce39155276935b523179b4fe4e01f85335.zip
Add passepartout, DTP application for X.
Diffstat (limited to 'graphics/passepartout/Makefile')
-rw-r--r--graphics/passepartout/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
new file mode 100644
index 000000000000..a2aae152c856
--- /dev/null
+++ b/graphics/passepartout/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: passepartout
+# Date created: 11st Sep 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= passepartout
+PORTVERSION= 0.2
+CATEGORIES= graphics gnome
+MASTER_SITES= http://www.stacken.kth.se/project/pptout/files/
+
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= passepartout-0.2-assert.patch \
+ passepartout-0.2-thread.patch
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= DTP application for X
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2 \
+ xml\\+\\+-0.1:${PORTSDIR}/textproc/libxml++
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnometarget gnomehack
+USE_LIBTOOL= yes
+
+# Fix for recent libxml++ API change
+post-patch:
+ @${FIND} ${WRKSRC}/src/pptout -name *.cc \
+ | grep -v -E 'pagesel|undodialog' \
+ | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|add_attribute|set_attribute|'
+
+.include <bsd.port.mk>