aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/peps/Makefile
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2001-07-07 11:52:10 +0800
committermarkp <markp@FreeBSD.org>2001-07-07 11:52:10 +0800
commit2870a30fc356b5fc9edc9404893b0d8e942ec444 (patch)
tree01f9a534d62b409db325fa9eae73d84eb8cf4c7c /graphics/peps/Makefile
parent90b6c3fe7779f2e2fac4b0ef34f0d2302e662db2 (diff)
downloadfreebsd-ports-gnome-2870a30fc356b5fc9edc9404893b0d8e942ec444.tar.gz
freebsd-ports-gnome-2870a30fc356b5fc9edc9404893b0d8e942ec444.tar.zst
freebsd-ports-gnome-2870a30fc356b5fc9edc9404893b0d8e942ec444.zip
Add peps 1.0, converts EPS images to anti-aliased PGM bitmaps.
PR: 28753 Submitted by: petef@databits.net
Diffstat (limited to 'graphics/peps/Makefile')
-rw-r--r--graphics/peps/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/graphics/peps/Makefile b/graphics/peps/Makefile
new file mode 100644
index 000000000000..b28bdd4d7309
--- /dev/null
+++ b/graphics/peps/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: peps
+# Date created: 5 July 2001
+# Whom: petef@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= peps
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.whizkidtech.net/peps/
+
+MAINTAINER= petef@databits.net
+
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript6 \
+ pnmtopng:${PORTSDIR}/graphics/netpbm
+
+post-patch:
+ @${PERL} -pi -e 's!cc -O3!${CC} ${CFLAGS}!' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/peps ${PREFIX}/bin
+
+.include <bsd.port.mk>