aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/peps/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:35:54 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:35:54 +0800
commit20111d6bfd52f61b0c0606f24b131b1ee8bdf721 (patch)
tree6093750fad8ce762e36ad3aa4aac31aa951f59da /graphics/peps/Makefile
parentf2e8639ee3b3f4e9e382a158b43f36876f3724f5 (diff)
downloadfreebsd-ports-gnome-20111d6bfd52f61b0c0606f24b131b1ee8bdf721.tar.gz
freebsd-ports-gnome-20111d6bfd52f61b0c0606f24b131b1ee8bdf721.tar.zst
freebsd-ports-gnome-20111d6bfd52f61b0c0606f24b131b1ee8bdf721.zip
[PATCH] graphics/peps: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54931 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics/peps/Makefile')
-rw-r--r--graphics/peps/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/peps/Makefile b/graphics/peps/Makefile
index 21b6a7d2a342..e944bdccd93b 100644
--- a/graphics/peps/Makefile
+++ b/graphics/peps/Makefile
@@ -15,11 +15,25 @@ MASTER_SITE_SUBDIR= petef
MAINTAINER= petef@FreeBSD.org
COMMENT= Converts EPS images to anti-aliased PGM bitmaps
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
pnmtopng:${PORTSDIR}/graphics/netpbm
USE_REINPLACE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's!cc -O3!${CC} ${CFLAGS}!' ${WRKSRC}/Makefile