aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pgperl/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1996-12-24 01:37:41 +0800
committerjmz <jmz@FreeBSD.org>1996-12-24 01:37:41 +0800
commit02b8664815ff6ae5dfc09d69afb05158f64d7e68 (patch)
tree61813a7f8e2bd89bf0e101cb4f509c897c8580ca /graphics/pgperl/Makefile
parent6881042c4b4cbe8c460b5a2a3080fabcbbab8751 (diff)
downloadfreebsd-ports-gnome-02b8664815ff6ae5dfc09d69afb05158f64d7e68.tar.gz
freebsd-ports-gnome-02b8664815ff6ae5dfc09d69afb05158f64d7e68.tar.zst
freebsd-ports-gnome-02b8664815ff6ae5dfc09d69afb05158f64d7e68.zip
A perl5 extension which makes available the pgplot library.
Diffstat (limited to 'graphics/pgperl/Makefile')
-rw-r--r--graphics/pgperl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/pgperl/Makefile b/graphics/pgperl/Makefile
new file mode 100644
index 000000000000..9cd7cf86ff5a
--- /dev/null
+++ b/graphics/pgperl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pgperl
+# Version required: 1.0
+# Date created: 22 December 1996
+# Whom: jmz
+#
+# $Id$
+#
+
+DISTNAME= PGPLOT1.0b_src
+EXTRACT_SUFX= .tar.Z
+PKGNAME= pgperl-1.0
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.ast.cam.ac.uk/pgperl/perl5/
+
+WRKSRC= ${WRKDIR}/PGPLOT
+ALL_TARGET= dynamic
+
+MAINTAINER= jmz@FreeBSD.org
+
+BUILD_DEPENDS= perl5.003
+LIB_DEPENDS= pgplot\\.5\\.
+RUN_DEPENDS= perl5.003
+
+post-install:
+ @mkdir -p ${PREFIX}/share/pgperl
+ @(cd ${WRKSRC}; cp LICENSE pgperl.doc testpg* ${PREFIX}/share/pgperl)
+
+.include <bsd.port.mk>