aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pgperl
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-17 03:46:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-17 03:46:59 +0800
commitb81afc9cc64e779ea249a9400ae28a601b80130e (patch)
tree84c8a2906035c9cc92a5d602260638cee8e4aeba /graphics/pgperl
parent1487745da9c05b3c45e7784fea16783d98ebb2c0 (diff)
downloadfreebsd-ports-gnome-b81afc9cc64e779ea249a9400ae28a601b80130e.tar.gz
freebsd-ports-gnome-b81afc9cc64e779ea249a9400ae28a601b80130e.tar.zst
freebsd-ports-gnome-b81afc9cc64e779ea249a9400ae28a601b80130e.zip
- Update to 2.21
- Respect PORTEXAMPLES - Pet portlint - Add WWW Changes: http://search.cpan.org/dist/PGPLOT/CHANGES
Diffstat (limited to 'graphics/pgperl')
-rw-r--r--graphics/pgperl/Makefile24
-rw-r--r--graphics/pgperl/distinfo4
-rw-r--r--graphics/pgperl/pkg-descr2
-rw-r--r--graphics/pgperl/pkg-plist36
4 files changed, 32 insertions, 34 deletions
diff --git a/graphics/pgperl/Makefile b/graphics/pgperl/Makefile
index 6b30f67cbefa..92bbff71cde4 100644
--- a/graphics/pgperl/Makefile
+++ b/graphics/pgperl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pgperl
-PORTVERSION= 2.20
-PORTREVISION= 1
+PORTVERSION= 2.21
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:KGB
@@ -16,24 +15,21 @@ DISTNAME= PGPLOT-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= A perl5 extension which makes available the pgplot library
+BUILD_DEPENDS= p5-ExtUtils-F77>=1.13:${PORTSDIR}/lang/p5-F77
LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
-BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77
-
-MAN3= PGPLOT.3
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+INSTALL_TARGET= pure_install
+SCRIPTS_ENV= PERL=${PERL}
USE_FORTRAN= g77
USE_PERL5= yes
-SCRIPTS_ENV= PERL=${PERL}
-INSTALL_TARGET= pure_install
-.include <bsd.port.pre.mk>
+MAN3= PGPLOT.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.ifndef(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}; ${INSTALL_DATA} LICENSE test* \
- ${EXAMPLESDIR})
+ ${MKDIR} ${EXAMPLESDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} LICENSE test* ${EXAMPLESDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pgperl/distinfo b/graphics/pgperl/distinfo
index b055414f70cd..872f33da32a1 100644
--- a/graphics/pgperl/distinfo
+++ b/graphics/pgperl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PGPLOT-2.20.tar.gz) = 4d3fe8770da527cb2e0df70b68e41dc80b8a8e421298df3c8b26cd03e431adae
-SIZE (PGPLOT-2.20.tar.gz) = 51774
+SHA256 (PGPLOT-2.21.tar.gz) = 1b81775a1769139ba615864c564b3f916973d162ee549cec42400345c528565d
+SIZE (PGPLOT-2.21.tar.gz) = 53431
diff --git a/graphics/pgperl/pkg-descr b/graphics/pgperl/pkg-descr
index 401b7a834c83..d07b2a30104a 100644
--- a/graphics/pgperl/pkg-descr
+++ b/graphics/pgperl/pkg-descr
@@ -6,3 +6,5 @@ but are transparent to the user.
See the file LICENSE in /usr/local/share/doc/pgperl for copyright/licensing
information and the file pgperl.doc on how to use pgplot from perl.
+
+WWW: http://search.cpan.org/dist/PGPLOT/
diff --git a/graphics/pgperl/pkg-plist b/graphics/pgperl/pkg-plist
index e9905f3127a1..e07d4472b4b0 100644
--- a/graphics/pgperl/pkg-plist
+++ b/graphics/pgperl/pkg-plist
@@ -1,21 +1,21 @@
%%SITE_PERL%%/%%PERL_ARCH%%/PGPLOT.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT/PGPLOT.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT/PGPLOT.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT/.packlist
-%%PORTDOCS%%%%EXAMPLESDIR%%/LICENSE
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.img
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.pl
-%%PORTDOCS%%%%EXAMPLESDIR%%/test1.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test10.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test11.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test12.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test2.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test3.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test4.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test5.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test6.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test7.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test8.p
-%%PORTDOCS%%%%EXAMPLESDIR%%/test9.p
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT/PGPLOT.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT/PGPLOT.so
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/LICENSE
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.img
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test10.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test11.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test12.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test3.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test4.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test5.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test6.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test7.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test8.p
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test9.p
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PGPLOT
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%