aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pgplot/Makefile
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1998-10-05 11:06:04 +0800
committersteve <steve@FreeBSD.org>1998-10-05 11:06:04 +0800
commit8b50ac6087d17925203f324fb7a72be884528484 (patch)
treecb34c07003d3b151289060af332d6a37b7580930 /graphics/pgplot/Makefile
parent8602429e298573a31545b6c8bec41dc8c9a4f9b3 (diff)
downloadfreebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.tar.gz
freebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.tar.zst
freebsd-ports-gnome-8b50ac6087d17925203f324fb7a72be884528484.zip
Convert to ELF.
Diffstat (limited to 'graphics/pgplot/Makefile')
-rw-r--r--graphics/pgplot/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/graphics/pgplot/Makefile b/graphics/pgplot/Makefile
index 81660913e855..0aedceae0523 100644
--- a/graphics/pgplot/Makefile
+++ b/graphics/pgplot/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.3 1997/07/17 15:12:44 max Exp $
+# $Id: Makefile,v 1.4 1997/08/15 13:36:01 jmz Exp $
#
DISTNAME= pgplot5.2
@@ -16,6 +16,15 @@ MAINTAINER= jmz@FreeBSD.org
WRKSRC= ${WRKDIR}/pgplot
post-install:
- ${LDCONFIG} -m ${PREFIX}/lib
+.for f in libcpgplot.so libpgplot.so
+ ${LN} -sf $f.${VERSION} ${PREFIX}/lib/$f
+.endfor
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 5
+.else
+VERSION= 5.2
+.endif