aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/php-libpuzzle
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2010-08-02 18:18:44 +0800
committerbapt <bapt@FreeBSD.org>2010-08-02 18:18:44 +0800
commit200eaba7d32368ad890fc8fec2c44ddcd176c388 (patch)
treed1b859926f7bff16e918f21f131d5a249172aa46 /graphics/php-libpuzzle
parentc73553da307c2c16b60c343e7547c05b9529686c (diff)
downloadfreebsd-ports-gnome-200eaba7d32368ad890fc8fec2c44ddcd176c388.tar.gz
freebsd-ports-gnome-200eaba7d32368ad890fc8fec2c44ddcd176c388.tar.zst
freebsd-ports-gnome-200eaba7d32368ad890fc8fec2c44ddcd176c388.zip
This is the PHP extension of the Puzzle library, which is is designed to
quickly find visually similar images (GIF, PNG, JPG), even if they have been resized, recompressed, recolored or slightly modified. The library is free, lightweight yet very fast, configurable, easy to use and it has been designed with security in mind. WWW: http://libpuzzle.pureftpd.org/project/libpuzzle/php PR: ports/146723 Submitted by: Naram Qashat <cyberbotx at cyberbotx.com> Approved by: jadawin@ (co-mentor)
Diffstat (limited to 'graphics/php-libpuzzle')
-rw-r--r--graphics/php-libpuzzle/Makefile35
-rw-r--r--graphics/php-libpuzzle/distinfo3
-rw-r--r--graphics/php-libpuzzle/pkg-descr7
3 files changed, 45 insertions, 0 deletions
diff --git a/graphics/php-libpuzzle/Makefile b/graphics/php-libpuzzle/Makefile
new file mode 100644
index 000000000000..47cb9a020b15
--- /dev/null
+++ b/graphics/php-libpuzzle/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: php-libpuzzle
+# Date created: 18 May 2010
+# Whom: Naram Qashat <cyberbotx@cyberbotx.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpuzzle
+PORTVERSION= 0.11
+CATEGORIES= graphics
+MASTER_SITES= http://download.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/release/ \
+ ftp://ftp.pureftpd.org/pub/pure-ftpd/misc/libpuzzle/releases/
+PKGNAMEPREFIX= php-
+
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= PHP extension for Puzzle library to find similar pictures
+
+LIB_DEPENDS= puzzle.1:${PORTSDIR}/graphics/libpuzzle \
+ gd.4:${PORTSDIR}/graphics/gd
+
+LICENSE= BSD
+LICENSE_FILES= ${WRKSRC}/COPYING
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/php/${PORTNAME}
+
+MAKE_JOBS_SAFE= yes
+
+USE_BZIP2= yes
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+USE_PHP_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/php-libpuzzle/distinfo b/graphics/php-libpuzzle/distinfo
new file mode 100644
index 000000000000..76b385a3d2b2
--- /dev/null
+++ b/graphics/php-libpuzzle/distinfo
@@ -0,0 +1,3 @@
+MD5 (libpuzzle-0.11.tar.bz2) = f9edc7322c6f422be395244eefbda180
+SHA256 (libpuzzle-0.11.tar.bz2) = ba628268df6956366cbd44ae48c3f1bab41e70b4737041a1f33dac9832c44781
+SIZE (libpuzzle-0.11.tar.bz2) = 404403
diff --git a/graphics/php-libpuzzle/pkg-descr b/graphics/php-libpuzzle/pkg-descr
new file mode 100644
index 000000000000..17340d988138
--- /dev/null
+++ b/graphics/php-libpuzzle/pkg-descr
@@ -0,0 +1,7 @@
+This is the PHP extension of the Puzzle library, which is is designed to
+quickly find visually similar images (GIF, PNG, JPG), even if they have been
+resized, recompressed, recolored or slightly modified.
+The library is free, lightweight yet very fast, configurable, easy to use
+and it has been designed with security in mind.
+
+WWW: http://libpuzzle.pureftpd.org/project/libpuzzle/php