aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/php-magickwand
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-01-19 05:12:42 +0800
committerkwm <kwm@FreeBSD.org>2015-01-19 05:12:42 +0800
commit0a6a81d4b6327ac4fd255009a1fb8f3179dbd4c2 (patch)
tree9382515fd441e0336df236e464a9bd7532cccaac /graphics/php-magickwand
parentbd87c1c5ce5f070fb73ee02ef0f7c77a95977107 (diff)
downloadfreebsd-ports-gnome-0a6a81d4b6327ac4fd255009a1fb8f3179dbd4c2.tar.gz
freebsd-ports-gnome-0a6a81d4b6327ac4fd255009a1fb8f3179dbd4c2.tar.zst
freebsd-ports-gnome-0a6a81d4b6327ac4fd255009a1fb8f3179dbd4c2.zip
Update ImageMagick to 6.9.0.4.
- Normalize the ImageMagick library name so it stays the same regardless of what the 16-bit and HDRI option are set to [1]. Teach cmake to look for the new name. Bump ports that link to the libraries due to this. - As a result do away with the "HALFSUPPORTED" option block, and list 16-bit and HDRI with the other options. - ImageMagick ships a basic SVG plugin when not using librsvg2 for SVG support. This basic SVG plugin needs libxml2 to work [2]. Make libxml2 a mandatory dependency (instead of only when the SVG option was selected). - Don't touch .keep files in the modules directory, there files there so it useless. PR: 194949 [1] PR: 195227 [2] Requested by: many [1] Submitted by: software-freebsd@interfasys.ch [2]
Diffstat (limited to 'graphics/php-magickwand')
-rw-r--r--graphics/php-magickwand/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/php-magickwand/Makefile b/graphics/php-magickwand/Makefile
index 4f08ebfbdba7..c40517bb4743 100644
--- a/graphics/php-magickwand/Makefile
+++ b/graphics/php-magickwand/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magickwand
PORTVERSION= 1.0.9
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.magickwand.org/download/php/
PKGNAMEPREFIX= php-
@@ -12,7 +12,7 @@ DISTNAME= MagickWandForPHP-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP extension to manipulate images
-LIB_DEPENDS= libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS= libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick
USES= pkgconfig
USE_PHP= yes
@@ -21,8 +21,8 @@ USE_PHPEXT= yes
CONFIGURE_ARGS= --with-magickwand=${LOCALBASE}
pre-configure:
- @${REINPLACE_CMD} -e 's|-lMagickWand|-lMagickWand-6.Q16|g' \
- -e 's|-lMagickCore|-lMagickCore-6.Q16|g' \
+ @${REINPLACE_CMD} -e 's|-lMagickWand|-lMagickWand-6|g' \
+ -e 's|-lMagickCore|-lMagickCore-6|g' \
${WRKSRC}/configure
.include <bsd.port.mk>