aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/php5-swfed
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-02-25 18:55:50 +0800
committertota <tota@FreeBSD.org>2011-02-25 18:55:50 +0800
commit4e7b3160077c476c17bfa44a6caebd14ef2ae5d7 (patch)
treea5f0cdcd51295c56f5b297a78981f5859f63625f /graphics/php5-swfed
parentccda87eb707162fefab85768f233506d237d89c9 (diff)
downloadfreebsd-ports-gnome-4e7b3160077c476c17bfa44a6caebd14ef2ae5d7.tar.gz
freebsd-ports-gnome-4e7b3160077c476c17bfa44a6caebd14ef2ae5d7.tar.zst
freebsd-ports-gnome-4e7b3160077c476c17bfa44a6caebd14ef2ae5d7.zip
- Fix pkg-plist
- Add x-generate-plist target to generate pkg-plist for maintenance Reported by: pointyhat (pav)
Diffstat (limited to 'graphics/php5-swfed')
-rw-r--r--graphics/php5-swfed/Makefile6
-rw-r--r--graphics/php5-swfed/pkg-plist2
2 files changed, 8 insertions, 0 deletions
diff --git a/graphics/php5-swfed/Makefile b/graphics/php5-swfed/Makefile
index f7c292073cdb..a9a6605f5d4f 100644
--- a/graphics/php5-swfed/Makefile
+++ b/graphics/php5-swfed/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swfed
PORTVERSION= 0.31
+PORTREVISION= 1
CATEGORIES= graphics www
MASTER_SITES= SFJP
MASTER_SITE_SUBDIR= ${PORTNAME}/51037
@@ -62,4 +63,9 @@ post-install:
@${CP} -R ${WRKDIR}/${DISTNAME}/www/ ${WWWDIR}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+x-generate-plist:
+ ${FIND} ${WWWDIR} -type f | ${SORT} | ${SED} -e 's,${WWWDIR},%%WWWDIR%%,g' >> pkg-plist.new
+ ${FIND} ${WWWDIR} -type d -depth | ${SORT} -r | ${SED} -e 's,${WWWDIR},@dirrm %%WWWDIR%%,g' >> pkg-plist.new
+ ${ECHO} '@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%' >> pkg-plist.new
+
.include <bsd.port.post.mk>
diff --git a/graphics/php5-swfed/pkg-plist b/graphics/php5-swfed/pkg-plist
index bc803755df3c..c9665077a6b3 100644
--- a/graphics/php5-swfed/pkg-plist
+++ b/graphics/php5-swfed/pkg-plist
@@ -1,7 +1,9 @@
%%WWWDIR%%/define.php
%%WWWDIR%%/index.php
+%%WWWDIR%%/shapetpl.swf
%%WWWDIR%%/swfimage.php
%%WWWDIR%%/swfimagelist.php
%%WWWDIR%%/swfimagereplace.php
+%%WWWDIR%%/swfshape.php
@dirrm %%WWWDIR%%
@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%