aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pixie
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /graphics/pixie
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'graphics/pixie')
-rw-r--r--graphics/pixie/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index ba93f0b065f5..566513aa9bad 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -29,7 +29,6 @@ USE_GNOME= gnomehack
USE_GL= glu
USE_BISON= build
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/pixie \
--libdir=${PREFIX}/lib/pixie \
--with-docdir=${DOCSDIR} \
@@ -46,8 +45,8 @@ MAN1= rndr.1 sdrc.1 sdrinfo.1 texmake.1
PORTDOCS= *
CFLAGS+= -fPIC
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>