aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pixmap/Makefile
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1995-02-19 11:22:36 +0800
committerjmz <jmz@FreeBSD.org>1995-02-19 11:22:36 +0800
commit5af4b45718010a80a57a450fde19890e9c964a2a (patch)
tree733a2893768569ae995dd7a9aef96f0348515c6e /graphics/pixmap/Makefile
parentaaf641e8c449dedf2cd5260560bd74b7caf5f17c (diff)
downloadfreebsd-ports-gnome-5af4b45718010a80a57a450fde19890e9c964a2a.tar.gz
freebsd-ports-gnome-5af4b45718010a80a57a450fde19890e9c964a2a.tar.zst
freebsd-ports-gnome-5af4b45718010a80a57a450fde19890e9c964a2a.zip
Pixmap is a pixmap editor based on XPM library
Diffstat (limited to 'graphics/pixmap/Makefile')
-rw-r--r--graphics/pixmap/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/pixmap/Makefile b/graphics/pixmap/Makefile
new file mode 100644
index 000000000000..5e595be2f217
--- /dev/null
+++ b/graphics/pixmap/Makefile
@@ -0,0 +1,31 @@
+USE_IMAKE= yes
+DISTNAME= pixmap
+LIB_DEPENDS= Xpm\\.3\\.:${PORTSDIR}/graphics/xpm
+MASTER_SITES= ftp://ftp.x.org/pub/R6untarred/contrib/programs/
+
+.if !defined(MASTER_SITE_OVERRIDE)
+
+fetch: pre-fetch
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @(cd ${DISTDIR}; \
+ for file in ${DISTFILES}; do \
+ if [ ! -f $$file -a ! -f `basename $$file` ]; then \
+ echo ">> $$file doesn't seem to exist on this system."; \
+ echo ">> Attempting to fetch it from a master site."; \
+ for site in ${MASTER_SITES}; do \
+ if ${NCFTP} -c ${NCFTPFLAGS} $${site}$${file} >$$file; then \
+ break; \
+ fi \
+ done; \
+ if [ ! -f $$file -a ! -f `basename $$file` ]; then \
+ echo ">> Couldn't fetch it - please try to retreive this";\
+ echo ">> port manually into ${DISTDIR} and try again."; \
+ exit 1; \
+ fi; \
+ fi \
+ done)
+.endif
+
+pre-patch:
+ @(cd ${WRKDIR}; mv pub/R6untarred/contrib/programs/pixmap .)
+.include <bsd.port.mk>