aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/plasma-kmod
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-04-20 05:28:59 +0800
committerjkim <jkim@FreeBSD.org>2012-04-20 05:28:59 +0800
commita2ad409f9fb5dd6d55a3e708309c4d04c7f8e407 (patch)
tree67195b15ba02c483feb206dd81f2c55aee894f90 /graphics/plasma-kmod
parent5fa8f2755e7c271234fea43f734e6883230e6589 (diff)
downloadfreebsd-ports-gnome-a2ad409f9fb5dd6d55a3e708309c4d04c7f8e407.tar.gz
freebsd-ports-gnome-a2ad409f9fb5dd6d55a3e708309c4d04c7f8e407.tar.zst
freebsd-ports-gnome-a2ad409f9fb5dd6d55a3e708309c4d04c7f8e407.zip
Do not round up the angle to avoid an out-of-boundary condition.
Diffstat (limited to 'graphics/plasma-kmod')
-rw-r--r--graphics/plasma-kmod/Makefile2
-rw-r--r--graphics/plasma-kmod/files/patch-plasma_saver.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/graphics/plasma-kmod/Makefile b/graphics/plasma-kmod/Makefile
index fcd775951ece..21a4f9eb7a6a 100644
--- a/graphics/plasma-kmod/Makefile
+++ b/graphics/plasma-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= plasma
PORTVERSION= 0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kld
MASTER_SITES= SF/futurebsd/futurebsd/${PORTNAME}
PKGNAMESUFFIX= -kmod
diff --git a/graphics/plasma-kmod/files/patch-plasma_saver.c b/graphics/plasma-kmod/files/patch-plasma_saver.c
index 69bc3c854f32..df7ec0479f30 100644
--- a/graphics/plasma-kmod/files/patch-plasma_saver.c
+++ b/graphics/plasma-kmod/files/patch-plasma_saver.c
@@ -42,7 +42,7 @@
/* theta now > 0, < 2pi, look up in table */
- apos = (int)((theta/TWO_PI)*90.0);
-+ apos = fdiv(fdiv(theta * SCALE, TWO_PI) * 90, SCALE);
++ apos = fdiv(theta * SCALE, TWO_PI) * 90 / SCALE;
return((neg) ? -aprsinv[apos] : aprsinv[apos]);
}