aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/plotutils/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2001-03-23 19:57:07 +0800
committertg <tg@FreeBSD.org>2001-03-23 19:57:07 +0800
commite1234dc7419b33dcf63532adcb9d15b065610973 (patch)
tree387ea7503606e353f6dd745b8cc4290c599d605a /graphics/plotutils/Makefile
parent898412613321324602ade0640b95a1798425ec21 (diff)
downloadfreebsd-ports-gnome-e1234dc7419b33dcf63532adcb9d15b065610973.tar.gz
freebsd-ports-gnome-e1234dc7419b33dcf63532adcb9d15b065610973.tar.zst
freebsd-ports-gnome-e1234dc7419b33dcf63532adcb9d15b065610973.zip
Upgrade to 2.4.1.
PR: 25997 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> (the maintainer doesn't seem to be active these days)
Diffstat (limited to 'graphics/plotutils/Makefile')
-rw-r--r--graphics/plotutils/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index c99905c50759..6993f073d4be 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -6,22 +6,27 @@
#
PORTNAME= plotutils
-PORTVERSION= 2.3
+PORTVERSION= 2.4.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= plotutils
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuckr@FreeBSD.org
-USE_XLIB= yes
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
+
+USE_NEWGCC= yes
+USE_MOTIF= yes
USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ MOTIFLIB="${MOTIFLIB}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-libplotter --enable-libxmi --with-motif
INSTALLS_SHLIB= yes
-USE_NEWGCC= yes
-CONFIGURE_ARGS= --enable-libplotter --enable-libxmi
-MAN1= ode.1 plot.1 spline.1 tek2plot.1
-USE_MOTIF= yes
-CONFIGURE_ARGS+= --with-motif
-CONFIGURE_ENV= MOTIFLIB="${MOTIFLIB}"
+MAN1= ode.1 plot.1 plotfont.1 spline.1 tek2plot.1
+
+pre-patch:
+ @${PERL} -pi -e 's|-lXm |\$$\{MOTIFLIB\} |g' ${WRKSRC}/configure
.include <bsd.port.mk>