aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/png2ico
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-15 08:54:19 +0800
committermarcus <marcus@FreeBSD.org>2003-04-15 08:54:19 +0800
commit42fff5ed29e87abd8bd9b2882c8f5f71e6e1da79 (patch)
tree34a3e3c7769e190d55cb65168cccf68bc67f845f /graphics/png2ico
parentd67cbd4f548f83d878b20bb2304c7ba2b4085e7b (diff)
downloadfreebsd-ports-gnome-42fff5ed29e87abd8bd9b2882c8f5f71e6e1da79.tar.gz
freebsd-ports-gnome-42fff5ed29e87abd8bd9b2882c8f5f71e6e1da79.tar.zst
freebsd-ports-gnome-42fff5ed29e87abd8bd9b2882c8f5f71e6e1da79.zip
Respect CFLAGS.
PR: 50961 Submitted by: maintainer
Diffstat (limited to 'graphics/png2ico')
-rw-r--r--graphics/png2ico/Makefile4
-rw-r--r--graphics/png2ico/files/patch-Makefile11
2 files changed, 11 insertions, 4 deletions
diff --git a/graphics/png2ico/Makefile b/graphics/png2ico/Makefile
index 22bf2cfc2f37..b0a3af104d14 100644
--- a/graphics/png2ico/Makefile
+++ b/graphics/png2ico/Makefile
@@ -20,6 +20,10 @@ MAN1= png2ico.1
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/graphics/png2ico/files/patch-Makefile b/graphics/png2ico/files/patch-Makefile
index d0ae605dbfec..39b52e7ebe66 100644
--- a/graphics/png2ico/files/patch-Makefile
+++ b/graphics/png2ico/files/patch-Makefile
@@ -1,8 +1,11 @@
---- Makefile.orig Sun Dec 8 14:50:10 2002
-+++ Makefile Sun Dec 8 14:50:17 2002
-@@ -1,4 +1,4 @@
+--- Makefile.orig Sat Dec 7 23:49:52 2002
++++ Makefile Tue Apr 15 02:32:25 2003
+@@ -1,6 +1,6 @@
-CPPFLAGS=-W -Wall -O2 -finline-functions
+CPPFLAGS=-W -Wall -O2 -finline-functions -I/usr/local/include -L/usr/local/lib
#CPPFLAGS=-O0 -W -Wall
- DEBUG=-g
+-DEBUG=-g
++#DEBUG=-g
+
+ all: png2ico