aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/png
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-18 18:48:06 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-18 18:48:06 +0800
commitf499dceb70e88a39bfc9a32c13f4a0851a189988 (patch)
tree3e3b8c5b90a5713945d83ba9ecbc03d799eb4bb4 /graphics/png
parent4bc597a25e6b86889ff2da2485e17bdd499711e2 (diff)
downloadfreebsd-ports-gnome-f499dceb70e88a39bfc9a32c13f4a0851a189988.tar.gz
freebsd-ports-gnome-f499dceb70e88a39bfc9a32c13f4a0851a189988.tar.zst
freebsd-ports-gnome-f499dceb70e88a39bfc9a32c13f4a0851a189988.zip
Link libpng library with libm, because it uses some math functions from it.
This should fix GNOME breakage introduced in the previous commit. Prompted by: Anders Andersson <anders@hack.org>
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/png/files/makefile.freebsd2
2 files changed, 3 insertions, 1 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 775906fb01d8..b15d2bc4a9ce 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
diff --git a/graphics/png/files/makefile.freebsd b/graphics/png/files/makefile.freebsd
index 4ce6a2170b2c..6b2dd459d9c3 100644
--- a/graphics/png/files/makefile.freebsd
+++ b/graphics/png/files/makefile.freebsd
@@ -22,6 +22,8 @@ MAN= libpng.3 libpngpf.3 png.5
MANDIR= /man/man
SYMLINKS= libpng/png.h ${INCSDIR}/../png.h \
libpng/pngconf.h ${INCSDIR}/../pngconf.h
+LDADD+= -lm
+DPADD+= ${LIBM}
CFLAGS+= -I. -DPNG_USE_PNGGCCRD
.if (${ARCH} != "i386")