aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/png
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-12-08 21:28:18 +0800
committernetchild <netchild@FreeBSD.org>2003-12-08 21:28:18 +0800
commit1e0e6c8f58f8e37fa8fda5c268db41a93356d750 (patch)
tree0c1d7471015f9eb6f6487c49e588723af3ade1d1 /graphics/png
parenta8dc33d1ff894dab85460126f4c65a59d0937192 (diff)
downloadfreebsd-ports-gnome-1e0e6c8f58f8e37fa8fda5c268db41a93356d750.tar.gz
freebsd-ports-gnome-1e0e6c8f58f8e37fa8fda5c268db41a93356d750.tar.zst
freebsd-ports-gnome-1e0e6c8f58f8e37fa8fda5c268db41a93356d750.zip
Add patch to allow advanced optimizations with icc (portrevision bumped).
This patch was tested with icc and gcc, the bugtracker ID @sf is: http://sourceforge.net/tracker/index.php?func=detail&aid=854293&group_id=5624&atid=105624 Fix suggested by: Intel Approved by: maintainer
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/png/files/patch-pnggccrd.c33
2 files changed, 34 insertions, 1 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 8617921b12ff..45e99d658f9a 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
diff --git a/graphics/png/files/patch-pnggccrd.c b/graphics/png/files/patch-pnggccrd.c
new file mode 100644
index 000000000000..4a6e690ace8f
--- /dev/null
+++ b/graphics/png/files/patch-pnggccrd.c
@@ -0,0 +1,33 @@
+--- pnggccrd.c.orig Thu Dec 4 15:52:22 2003
++++ pnggccrd.c Thu Dec 4 16:00:18 2003
+@@ -1767,7 +1767,8 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width) // ecx
++ "0" (width), // ecx
++ "rim" (_const4)
+ // doesn't work "i" (0x0000000000FFFFFFLL) // %1 (a.k.a. _const4)
+
+ #if 0 /* %mm0, ..., %mm4 not supported by gcc 2.7.2.3 or egcs 1.1 */
+@@ -1811,7 +1812,8 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width) // ecx
++ "0" (width), // ecx
++ "rim" (_const4)
+
+ #if 0 /* %mm0, ..., %mm2 not supported by gcc 2.7.2.3 or egcs 1.1 */
+ : "%mm0", "%mm1", "%mm2" // clobber list
+@@ -1865,7 +1867,9 @@
+
+ : "1" (sptr), // esi // input regs
+ "2" (dp), // edi
+- "0" (width_mmx) // ecx
++ "0" (width_mmx), // ecx
++ "rim" (_const4),
++ "rim" (_const6)
+
+ #if 0 /* %mm0, ..., %mm3 not supported by gcc 2.7.2.3 or egcs 1.1 */
+ : "%mm0", "%mm1" // clobber list