aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/png
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-12-09 02:23:29 +0800
committerantoine <antoine@FreeBSD.org>2015-12-09 02:23:29 +0800
commita8fbb32047f9bef02c4966998af0899be0ff92f1 (patch)
tree34dc41b98b34a05f960b48f2e738cefd78e60add /graphics/png
parente65ad9018e955cf0360f805fa68c2d9b315ead2c (diff)
downloadfreebsd-ports-gnome-a8fbb32047f9bef02c4966998af0899be0ff92f1.tar.gz
freebsd-ports-gnome-a8fbb32047f9bef02c4966998af0899be0ff92f1.tar.zst
freebsd-ports-gnome-a8fbb32047f9bef02c4966998af0899be0ff92f1.zip
Do not fail the build if regression tests do not pass, there seems to
be a regression on big endian archs between versions 1.6.19 and 1.6.20 (reported upstream) PR: 205125 MFH: 2015Q4
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 7f76fb96f5a5..0cde498feebe 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -30,15 +30,14 @@ PNGTEST_DESC=Enable Regression Test (recommended)
PATCHFILES= ${DISTNAME}-apng.patch.gz
.endif
+# Do not fail until https://sourceforge.net/p/libpng/bugs/243/ is fixed
.if ${PORT_OPTIONS:MPNGTEST}
post-build:
(cd ${BUILD_WRKSRC}; if ! ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} test; then \
- if [ x != x${BUILD_FAIL_MESSAGE} ] ; then \
- ${ECHO_MSG} "===> Compilation failed unexpectedly."; \
- (${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
- fi; \
- ${FALSE}; \
- fi)
+ if [ -f ${WRKSRC}/test-suite.log ]; then \
+ ${CAT} ${WRKSRC}/test-suite.log ; \
+ fi; \
+ fi)
.endif
.include <bsd.port.mk>