aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pngnq/Makefile
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-04-21 04:02:25 +0800
committerbeech <beech@FreeBSD.org>2011-04-21 04:02:25 +0800
commit349701c1b730dfef00ac6c518b0823b7e45a2bfb (patch)
treeb215f2d53fefa93dcdbf9b1ea28d5a169535b77c /graphics/pngnq/Makefile
parente3c171b3a9e35f0b0c67ecf1563ade605084563a (diff)
downloadfreebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.tar.gz
freebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.tar.zst
freebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.zip
- Update to 1.0
PR: ports/156417 Submitted by: Anton Yuzhaninov (citrin@citrin.ru) Approved by: (stb@lassitu.de)(maintainer) itetcu (mentor)(implicit)
Diffstat (limited to 'graphics/pngnq/Makefile')
-rw-r--r--graphics/pngnq/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/graphics/pngnq/Makefile b/graphics/pngnq/Makefile
index 540380192b96..3df4d968c543 100644
--- a/graphics/pngnq/Makefile
+++ b/graphics/pngnq/Makefile
@@ -6,40 +6,30 @@
#
PORTNAME= pngnq
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= graphics
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= stb@lassitu.de
COMMENT= A tool for quantizing PNG images in RGBA format
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
-WRKSRC= ${WRKDIR}/${PORTVERSION}
+GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -DVERSION='\"${PORTVERSION}\"'" \
- LDFLAGS="-lpng -lz -lm -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" LIBS=-lpng
-PORTDOCS= README LICENSE README.pngcomp
+PORTDOCS= README COPYING
PLIST_FILES= bin/pngcomp bin/pngnq
-.if !defined(NO_INSTALL_MANPAGES)
MAN1= pngnq.1
-.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pngcomp ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/pngnq ${PREFIX}/bin
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/pngnq.1 ${MAN1PREFIX}/man/man1
-.endif
.include <bsd.port.mk>