aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pngnq
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-04-21 04:02:25 +0800
committerbeech <beech@FreeBSD.org>2011-04-21 04:02:25 +0800
commit349701c1b730dfef00ac6c518b0823b7e45a2bfb (patch)
treeb215f2d53fefa93dcdbf9b1ea28d5a169535b77c /graphics/pngnq
parente3c171b3a9e35f0b0c67ecf1563ade605084563a (diff)
downloadfreebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.tar.gz
freebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.tar.zst
freebsd-ports-gnome-349701c1b730dfef00ac6c518b0823b7e45a2bfb.zip
- Update to 1.0
PR: ports/156417 Submitted by: Anton Yuzhaninov (citrin@citrin.ru) Approved by: (stb@lassitu.de)(maintainer) itetcu (mentor)(implicit)
Diffstat (limited to 'graphics/pngnq')
-rw-r--r--graphics/pngnq/Makefile22
-rw-r--r--graphics/pngnq/distinfo5
-rw-r--r--graphics/pngnq/files/patch-errors.h18
-rw-r--r--graphics/pngnq/files/patch-pngcomp.c10
-rw-r--r--graphics/pngnq/files/patch-rwpng.c11
5 files changed, 26 insertions, 40 deletions
diff --git a/graphics/pngnq/Makefile b/graphics/pngnq/Makefile
index 540380192b96..3df4d968c543 100644
--- a/graphics/pngnq/Makefile
+++ b/graphics/pngnq/Makefile
@@ -6,40 +6,30 @@
#
PORTNAME= pngnq
-PORTVERSION= 0.5
-PORTREVISION= 2
+PORTVERSION= 1.0
CATEGORIES= graphics
MASTER_SITES= SF
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= stb@lassitu.de
COMMENT= A tool for quantizing PNG images in RGBA format
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
-WRKSRC= ${WRKDIR}/${PORTVERSION}
+GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -DVERSION='\"${PORTVERSION}\"'" \
- LDFLAGS="-lpng -lz -lm -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" LIBS=-lpng
-PORTDOCS= README LICENSE README.pngcomp
+PORTDOCS= README COPYING
PLIST_FILES= bin/pngcomp bin/pngnq
-.if !defined(NO_INSTALL_MANPAGES)
MAN1= pngnq.1
-.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pngcomp ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/pngnq ${PREFIX}/bin
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/pngnq.1 ${MAN1PREFIX}/man/man1
-.endif
.include <bsd.port.mk>
diff --git a/graphics/pngnq/distinfo b/graphics/pngnq/distinfo
index bfb218ee9332..822d46d6d802 100644
--- a/graphics/pngnq/distinfo
+++ b/graphics/pngnq/distinfo
@@ -1,3 +1,2 @@
-MD5 (pngnq-0.5-src.tar.gz) = 14aff764008dfd55e816d3fe08636cb9
-SHA256 (pngnq-0.5-src.tar.gz) = c9f2f4239e07d23064176909cd59ef12d96573599a3fa29bed59fe554b769b92
-SIZE (pngnq-0.5-src.tar.gz) = 26115
+SHA256 (pngnq-1.0.tar.gz) = 3413cb72af4e1a25268892ad182f6f9f516c5b67d9ff873968e5a60c293c00a7
+SIZE (pngnq-1.0.tar.gz) = 105155
diff --git a/graphics/pngnq/files/patch-errors.h b/graphics/pngnq/files/patch-errors.h
new file mode 100644
index 000000000000..b230035ad678
--- /dev/null
+++ b/graphics/pngnq/files/patch-errors.h
@@ -0,0 +1,18 @@
+--- src/errors.h.orig 2011-04-14 19:57:13.000000000 +0400
++++ src/errors.h 2011-04-14 20:00:25.000000000 +0400
+@@ -20,9 +20,11 @@
+ PNGNQ_LOG_ERR(__VA_ARGS__)\
+ fflush(stderr);
+
+-#define PNGNQ_WARNING(...) (fprintf(stderr,"pngnq - Warning: "));\
+- fprintf(stderr, __VA_ARGS__);\
+- PNGNQ_LOG_WARNING(__VA_ARGS__)\
+- fflush(stderr);
++#define PNGNQ_WARNING(...) \
++ do { \
++ fprintf(stderr, "pngnq - Warning: " __VA_ARGS__); \
++ PNGNQ_LOG_WARNING(__VA_ARGS__) \
++ fflush(stderr); \
++ } while (0)
+
+ #define PNGNQ_MESSAGE(...) {if(verbose) {fprintf(stderr,__VA_ARGS__);fflush(stderr);}}
diff --git a/graphics/pngnq/files/patch-pngcomp.c b/graphics/pngnq/files/patch-pngcomp.c
deleted file mode 100644
index 9fd8e2c1e76a..000000000000
--- a/graphics/pngnq/files/patch-pngcomp.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- pngcomp.c.orig 2007-11-12 13:59:38.000000000 +0100
-+++ pngcomp.c 2009-05-10 15:07:38.000000000 +0200
-@@ -41,6 +41,7 @@
- #include <string.h>
- #include <math.h>
- #include <ctype.h>
-+#include <unistd.h>
-
- #include "png.h"
- #include "rwpng.h"
diff --git a/graphics/pngnq/files/patch-rwpng.c b/graphics/pngnq/files/patch-rwpng.c
deleted file mode 100644
index 195051162411..000000000000
--- a/graphics/pngnq/files/patch-rwpng.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- rwpng.c.orig 2006-06-15 11:39:29.000000000 +0200
-+++ rwpng.c 2010-03-29 15:35:32.000000000 +0200
-@@ -77,7 +77,7 @@
- * have used slightly more general png_sig_cmp() function instead */
-
- fread(sig, 1, 8, infile);
-- if (!png_check_sig(sig, 8)) {
-+ if (png_sig_cmp(sig, 0, 8)) {
- mainprog_ptr->retval = 21; /* bad signature */
- return mainprog_ptr->retval;
- }