aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/pstoepsi
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:41:12 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:41:12 +0800
commit0a99e9883f801e540a29602334d09f06a4424ec5 (patch)
tree7cefb65cb4226b91df1693158120c6f72d82eda4 /graphics/pstoepsi
parentc6a641e96960ea164e1f851f69b0fb08a5797e35 (diff)
downloadfreebsd-ports-gnome-0a99e9883f801e540a29602334d09f06a4424ec5.tar.gz
freebsd-ports-gnome-0a99e9883f801e540a29602334d09f06a4424ec5.tar.zst
freebsd-ports-gnome-0a99e9883f801e540a29602334d09f06a4424ec5.zip
[PATCH] graphics/pstoepsi: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54933 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics/pstoepsi')
-rw-r--r--graphics/pstoepsi/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/pstoepsi/Makefile b/graphics/pstoepsi/Makefile
index 889d81c015c8..f09367980c3c 100644
--- a/graphics/pstoepsi/Makefile
+++ b/graphics/pstoepsi/Makefile
@@ -16,13 +16,27 @@ EXTRACT_ONLY= #empty
MAINTAINER= mita@FreeBSD.org
COMMENT= Wiliam Chia-Wei Cheng's yet another PS to EPSI converter
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
RUN_DEPENDS= pbmtoepsi:${PORTSDIR}/graphics/netpbm \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
NO_WRKSUBDIR= yes
.SILENT:
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
pre-patch:
${CP} ${DISTDIR}/${DIST_SUBDIR}/pstoepsi ${WRKDIR}/pstoepsi.prefix
${CP} ${DISTDIR}/${DIST_SUBDIR}/README.this-site ${WRKDIR}