aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-amanith
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /graphics/py-amanith
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'graphics/py-amanith')
-rw-r--r--graphics/py-amanith/files/patch-setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/py-amanith/files/patch-setup.py b/graphics/py-amanith/files/patch-setup.py
index 2aaca0ef825e..5d3ee2be7615 100644
--- a/graphics/py-amanith/files/patch-setup.py
+++ b/graphics/py-amanith/files/patch-setup.py
@@ -5,21 +5,21 @@
from os.path import join
+LOCALBASE = os.environ['LOCALBASE']
-+X11BASE = os.environ['X11BASE']
++LOCALBASE = os.environ['LOCALBASE']
+
try:
amanith_base = os.environ["AMANITHDIR"]
except:
- amanith_base = "amanith"
+ amanith_base = os.environ['LOCALBASE']
-+ X11BASE = os.environ['X11BASE']
++ LOCALBASE = os.environ['LOCALBASE']
debug = False
libs = ["amanith"]
-inc = [join("changes", "include"), join(amanith_base, "include"), "include"]
-lib = [join(amanith_base, "lib")]
-+inc = [join("changes", "include"), join(amanith_base, "include"), join(X11BASE,"include") ,"include"]
-+lib = [join(amanith_base, "lib"), join(X11BASE, "lib")]
++inc = [join("changes", "include"), join(amanith_base, "include"), join(LOCALBASE,"include") ,"include"]
++lib = [join(amanith_base, "lib"), join(LOCALBASE, "lib")]
cc_args = []
swig_args = ["-Ibuild/amanith"]