aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-chart/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:41:49 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:41:49 +0800
commit32cf729c397ba160dbef8bebd285de629d8ee5f9 (patch)
treecd7eb979fc43ff5ea0fdcae32e458f2b7852fc67 /graphics/py-chart/Makefile
parent0a99e9883f801e540a29602334d09f06a4424ec5 (diff)
downloadfreebsd-ports-gnome-32cf729c397ba160dbef8bebd285de629d8ee5f9.tar.gz
freebsd-ports-gnome-32cf729c397ba160dbef8bebd285de629d8ee5f9.tar.zst
freebsd-ports-gnome-32cf729c397ba160dbef8bebd285de629d8ee5f9.zip
[PATCH] graphics/py-chart: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54934 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'graphics/py-chart/Makefile')
-rw-r--r--graphics/py-chart/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/py-chart/Makefile b/graphics/py-chart/Makefile
index 781fdb9e0e90..5a6586238d74 100644
--- a/graphics/py-chart/Makefile
+++ b/graphics/py-chart/Makefile
@@ -16,9 +16,23 @@ DISTNAME= PyChart-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Create high quality Encapsulated Postscript, PDF, or PNG charts
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
.include <bsd.port.mk>