aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-gd/Makefile
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-07-24 04:39:48 +0800
committerperky <perky@FreeBSD.org>2002-07-24 04:39:48 +0800
commit807cfb304a5b119f050e2e24b4297c90ef55727c (patch)
tree150a9eb4937f518cd1d0f12bfd4d09b419aba442 /graphics/py-gd/Makefile
parent45971483e90141daafc9d5e77f4c5c4fb38ffb94 (diff)
downloadfreebsd-ports-gnome-807cfb304a5b119f050e2e24b4297c90ef55727c.tar.gz
freebsd-ports-gnome-807cfb304a5b119f050e2e24b4297c90ef55727c.tar.zst
freebsd-ports-gnome-807cfb304a5b119f050e2e24b4297c90ef55727c.zip
Update to 0.30
Diffstat (limited to 'graphics/py-gd/Makefile')
-rw-r--r--graphics/py-gd/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
index a57873efa5c5..c6ff26edd7bb 100644
--- a/graphics/py-gd/Makefile
+++ b/graphics/py-gd/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= gd
-PORTVERSION= 0.26
+PORTVERSION= 0.30
CATEGORIES= graphics python
MASTER_SITES= http://newcenturycomputers.net/projects/download.cgi/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,26 +15,19 @@ MAINTAINER= perky@FreeBSD.org
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
-USE_PYTHON= yes
-USE_REINPLACE= yes
-PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g} \
- EXAMPLE_DIR=${EXAMPLE_DIR:S,^${PREFIX}/,,g}
-EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-
-.if !defined(WITHOUT_X11)
USE_XPM= yes
-.endif
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+PYSETUP= Setup.py
+EXAMPLE_DIR= ${PREFIX}/share/examples/py-gd
post-patch:
- ${REINPLACE_CMD} -e 's,^\(gd.*\)$$,\1 -I${LOCALBASE}/include/gd\
- -L${LOCALBASE}/lib,g' -e 's,-lttf,,g' \
- -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/Setup
-.if defined(WITHOUT_X11)
- ${REINPLACE_CMD} -e 's,-lX11 -lXpm,,g' ${WRKSRC}/Setup
-.endif
-
-pre-build:
- cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
+ ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ -e 's,/usr/X11R6,${X11BASE},g' \
+ -e 's,/usr/include/X11,${LOCALBASE}/include/gd,g' \
+ ${WRKSRC}/${PYSETUP}
post-install:
.if !defined(NOPORTDOCS)