aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-gd
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2001-12-22 21:11:19 +0800
committerkevlo <kevlo@FreeBSD.org>2001-12-22 21:11:19 +0800
commit9f61611c38416a77b725a9aa065f18c7bd0dbaa0 (patch)
treebc3f3df9917fff61f65670fbe828a4f036f0326c /graphics/py-gd
parent370462d6d79b927c31aa670689d6096123472d3d (diff)
downloadfreebsd-ports-gnome-9f61611c38416a77b725a9aa065f18c7bd0dbaa0.tar.gz
freebsd-ports-gnome-9f61611c38416a77b725a9aa065f18c7bd0dbaa0.tar.zst
freebsd-ports-gnome-9f61611c38416a77b725a9aa065f18c7bd0dbaa0.zip
Initial import of py-gd 0.26.
This is the Python interface to the GD library. PR: 33088 Submitted by: Hye-Shik Chang <perky@fallin.lv>
Diffstat (limited to 'graphics/py-gd')
-rw-r--r--graphics/py-gd/Makefile44
-rw-r--r--graphics/py-gd/distinfo1
-rw-r--r--graphics/py-gd/pkg-comment1
-rw-r--r--graphics/py-gd/pkg-descr4
-rw-r--r--graphics/py-gd/pkg-plist3
5 files changed, 53 insertions, 0 deletions
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
new file mode 100644
index 000000000000..46aa621cc79c
--- /dev/null
+++ b/graphics/py-gd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: py-gd
+# Date created: 23 December 2001
+# Whom: Hye-Shik Chang <perky@fallin.lv>
+#
+# $FreeBSD$
+
+PORTNAME= gd
+PORTVERSION= 0.26
+CATEGORIES= graphics python
+MASTER_SITES= http://newcenturycomputers.net/projects/download.cgi/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= gdmodule-${PORTVERSION}
+
+MAINTAINER= perky@fallin.lv
+
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
+ ttf.4:${PORTSDIR}/print/freetype
+
+USE_PYTHON= yes
+EXCMD= /usr/bin/ex
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g} \
+ EXAMPLE_DIR=${EXAMPLE_DIR:S,^${PREFIX}/,,g}
+EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+.if !defined(WITHOUT_X11)
+USE_XPM= yes
+.endif
+
+post-patch:
+ ${EXCMD} -c 's,^\(gd.*\)$$,\1 -I${PREFIX}/include/gd,g|wq!' ${WRKSRC}/Setup
+.if defined(WITHOUT_X11)
+ ${EXCMD} -c 's,-lX11 -lXpm,,g|wq!' ${WRKSRC}/Setup
+.endif
+
+pre-build:
+ cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLE_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/gddemo.py ${EXAMPLE_DIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/py-gd/distinfo b/graphics/py-gd/distinfo
new file mode 100644
index 000000000000..41a5d0ce2ae0
--- /dev/null
+++ b/graphics/py-gd/distinfo
@@ -0,0 +1 @@
+MD5 (gdmodule-0.26.tar.gz) = fc171fa4cab20a73b8c4d073c2f753f4
diff --git a/graphics/py-gd/pkg-comment b/graphics/py-gd/pkg-comment
new file mode 100644
index 000000000000..7f84f9399386
--- /dev/null
+++ b/graphics/py-gd/pkg-comment
@@ -0,0 +1 @@
+Python interface to the GD library
diff --git a/graphics/py-gd/pkg-descr b/graphics/py-gd/pkg-descr
new file mode 100644
index 000000000000..fcc5d586b11f
--- /dev/null
+++ b/graphics/py-gd/pkg-descr
@@ -0,0 +1,4 @@
+GD module is an interface to the GD library written by Thomas Bouttel.
+It has been extended in some ways from the original GD library.
+
+WWW: http://newcenturycomputers.net/projects/gdmodule.html
diff --git a/graphics/py-gd/pkg-plist b/graphics/py-gd/pkg-plist
new file mode 100644
index 000000000000..ec5ea608efd4
--- /dev/null
+++ b/graphics/py-gd/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/gdmodule.so
+%%PORTDOCS%%%%EXAMPLE_DIR%%/gddemo.py
+%%PORTDOCS%%@dirrm %%EXAMPLE_DIR%%