aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/py-imaging
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-23 10:35:26 +0800
committerjgh <jgh@FreeBSD.org>2013-05-23 10:35:26 +0800
commitae39fc48dcdf2a3d8613eb03f67731d1b6ad6001 (patch)
tree989dd8e1b1e6c8900e5268efdd3d75a25a3b7268 /graphics/py-imaging
parentc320816067bbebb0b0f197bcee87ac7785eb832c (diff)
downloadfreebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.tar.gz
freebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.tar.zst
freebsd-ports-gnome-ae39fc48dcdf2a3d8613eb03f67731d1b6ad6001.zip
- adoption of optionsNG
- convert to USES in some cases (pkgconfig,pathfix) - trim COMMENT/historical headers in some cases Approved by: portmgr (miwi)
Diffstat (limited to 'graphics/py-imaging')
-rw-r--r--graphics/py-imaging/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/graphics/py-imaging/Makefile b/graphics/py-imaging/Makefile
index 01eff39fde37..05675b900cf6 100644
--- a/graphics/py-imaging/Makefile
+++ b/graphics/py-imaging/Makefile
@@ -30,11 +30,14 @@ PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-OPTIONS= TKINTER "Build with tkinter for X support" on
+OPTIONS_DEFINE= TKINTER
+TKINTER_DESC= tkinter for X support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= TKINTER
-.if !defined(WITHOUT_TKINTER)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTKINTER}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
PLIST_SUB+= TKINTER=""
@@ -42,7 +45,7 @@ PLIST_SUB+= TKINTER=""
PLIST_SUB+= TKINTER="@comment "
.endif
-.if defined(WITHOUT_TKINTER)
+.if ! ${PORT_OPTIONS:MTKINTER}
post-patch:
@${REINPLACE_CMD} -e 's|if _tkinter|if None|g' ${WRKSRC}/setup.py
.endif
@@ -53,9 +56,9 @@ post-install:
.endfor
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Scripts/* ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>